"Update cannot continue"



  • I have now twice tried to use the auto upgrade feature in my 1.2.1 install and both time it failed. This second time I was sitting watching the download complete to 100% and then a few moments after the single phrase "Update cannot continue" was shown. Nothing else.

    Can someone tell me what conditions could trigger this message?

    I guess there's no problem lying around after such failed upgrade attempts? pfSeense flushes downloaded stuff etc I guess.

    The upgrade was using default settings.

    TIA



  • Were you upgrading from the web admin interface or from the console (ssh or physical).  I suggest running the upgrade from the console if you weren't before.



  • Hi,

    I was doing it through the web admin interface.

    Since I don't have a monitor attached at all times I'll test a ssh logon insted then.



  • Ok then..

    I started the install through ssh and it wanted me to add URL and so I did.
    After the download it gave me some "errors" indicating that it couldn't find a md5 file in the same directory where the download file was (and this seemed to be correct since I only saw a file named "latest.tgz.sha256" there, no file indicating something with md5.

    Is this something incorrect with the installer that it is looking for an old type of hash file?

    Anyway, I seem to have ended up with 1.2.2 so it worked, but when it prompted me that it wouldn't be able to check the file, due to the lack of the md5 file, then I really should've had the option to somehow stop the upgrade I think.

    So, I guess my download was not verified now or how should I read this?

    I noticed - since I switched to the web interface after the console died during the update/reboot - that a number of packages were removed and then reinstalled again. Is this process automated, that packages that exists in newer versions are updated during a system update?

    TIA



  • You'll have to upgrade to 1.2.2 before Auto Update will work. Use one of the other upgrade mechanisms.



  • same problem i had in the this post I described in post with subject "upgrade problem"


Locked