High CPU usage by "WinHTTP Web Proxy Auto-Discovery Service" when coming off Wi-



  • I have an issue where the Windows “WinHTTP Web Proxy Auto-Discovery Service” consumes high CPU usage.

    This occurs when a Wi-Fi card that has an established connection to a network, is disconnected - either switching off Wi-Fi or plugging in an ethernet cable. When this happens, the WinHTTP Web Proxy Auto-Discovery Service starts and consumes ~7% CPU - but this will grow to as much as 100% as applications need to use the internet.

    Once the service is in this state - the only way to recover is to reboot.

    I can switch between the LAN Wi-Fi to the guest Wi-Fi without issue. Once I have disabled Wi-Fi and rebooted after the “WinHTTP Web Proxy Auto-Discovery” service issue, I can connect and disconnect an ethernet cable without any issue. I’ve even used a USB to ethernet adaptor and switched between two NICs running on the same laptop with no issue.

    The problem seems to be when a Wi-Fi connection is stopped.

    I have this issue with a Dell XPS 9560 and Dell M3800 laptops, plus an Asus S200E notebook all running Win 10.
    I thought that it might have been something to do with my home network - but I have tried this at another house and the corporate Wi-Fi at work and still get the same issue (although it was a bit more hit and miss on the corporate network).

    I’ve been working with Dell support trying to get this fixed, but I think they are out of their depth. We’ve tried rolling back drivers, the BIOS etc but nothing makes a difference.

    I’m convinced that a Win 10 update is the cause of the issue - which started around mid-late Jan.

    Does anyone have any idea what might be causing this?
    Is anyone else able to reproduce this on their kit?



  • Turns out that this is a bug in Windows that was introduced by the 1709 feature update.

    I found a laptop that hadn’t been used for a few months, so started installing Windows updates and testing the Wi-Fi disconnect after each update.

    No issues until the 1709 update is installed. So I am now able to reproduce this on 4 laptops.

    Is there anything in PFSense that was updated since 2.3.4-Release-p1 that might fix this?

    I’m wary of updating to 2.4.0 in case it breaks my OpenVPN setup (which took a week to get working on all clients).


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy