Acesso exteno ao pfsense



  • Galera boa tarde.
    Estou precisando de uma ajuda dos universitários e o seguinte eu instalei um pf em um lab virtual fiz as configurações para acesso de fora simulando minha maquina física com estando em outro ambiente acessei de boa, mas quando configuro um pf em uma maquina física e faço as regras de nat permitindo acesso, não vai nem a paulada, detalhe configurei um ddns noip coloquei meu modem em dmz porque em bridge o meu pf nao consegue detectar o ip que a operadora esta entregando, ai mudei de tática desabilitei o dmz e fiz redirecionamento de porta tentei varias portas inclusive portas altas, no meu ddns mostra o ip verdinho tudo ok mas nem mesmo pinga, detalhe ja criei a regra permitindo icmp já não sai mas como proceder se alguém já passou por isso e puder me ajudar?



  • Aldenir,

    o que você está chamando de "acesso de fora"? Você quer acessar a pagina de gerenciamento do pfsense? Você quer acessar hosts hospedados atrás do pfsense?

    Se for acesso ao webconfigurator via endereço WAN, precisa ser habilitado explicitamente como uma regra no firewall.

    Veja o exemplo no final, que é do tipo mais inseguro (qualquer IP da internet com possibilidade de acessar o webconfigurator).

    https://doc.pfsense.org/index.php/Remote_firewall_Administration



  • Isso mesmo jorlando, acesso ao webconfigurator via endereço WAN, mas eu ja criei uma regra veja como esta e mesmo assim nao funciona ja liberei porta no modem ja deixei em dmz e nada nem mesmo pingo.




  • @ALDENIR:

    Isso mesmo jorlando, acesso ao webconfigurator via endereço WAN, mas eu ja criei uma regra veja como esta e mesmo assim nao funciona ja liberei porta no modem ja deixei em dmz e nada nem mesmo pingo.

    Caro Adenir, se o seu modem está configurando em modo "router" entregando a você um IP privado, deverá criar uma porta alta e realizar o redirecionamento para o endereço da sua WAN!

    Abraços



  • Meu caro pode me dar um ex a partir de quais portas voces começam a utilizar neste caso?



  • @ALDENIR:

    Isso mesmo jorlando, acesso ao webconfigurator via endereço WAN, mas eu ja criei uma regra veja como esta e mesmo assim nao funciona ja liberei porta no modem ja deixei em dmz e nada nem mesmo pingo.

    Com o IP interno da rede, vc não conseguira acessar externamente.

    Vamos seguir alguns passos básicos.

    1- O seu link possui IP Privado?

    2- Seu modem da operadora em modo Bridge?

    =====
    Presumindo que seu link tenha IP Privado e tbm o seu modem esteja em Bridge!!

    Cirei em Regras>>Firewall>> WAN

    Libera o Acesso somente para  Porta.

    Dica: Por segurança eu mudaria a porta de acesso do Webconfigurator… sei coloque um valor alto EX:9090 ou 5080...etc use sua criatividade.

    =====
    Agora presumindo que vc não tenha IP Privado ou seu modem está como router.

    nesse caso teria alguns passos para se fazer, até conseguir o acesso.

    Nos conte como esta sua rede?



  • Aldenir,

    sua regra está errada. 192.168.x.x é um IP privado, não pode ser acessado pela Internet.

    Siga o exemplo da página que indiquei e ao invés de 192.168.x.x você coloca "WAN address" (como na linha de cima onde você permitiu ping na porta WAN).

    Por que você não cria um túnel IPSEC para poder acessar sua rede LAN à partir da internet? Muito mais seguro do que habilitar a gerência via WAN.



  • Boa tarde galera.
    Meu cenário e apenas te teste, mas com o objetivo de depois fazer uma vpn site to site e vejo que isso sera um problema, eu não possuo ip fixo real e meu modem não funcionou em bridge so em router mudei a regra conforme me recomendaram alterei minha porta do meu webadmin para uma porta mais alta e fui no modem e redirecionei para a porta desejada alterei a regra conforme o link que foi passado meu ddns esta batendo com o que esta no meu pf mas mesmo assim nem ao menos pingo eu uso esse maldito modem Humax HGB10R-02.
    E agora qual direção seguir ?



  • Observem minhas regras como estão.

    ![Sem título.png](/public/imported_attachments/1/Sem título.png)
    ![Sem título.png_thumb](/public/imported_attachments/1/Sem título.png_thumb)



  • Galera obrigado pela força mas consegui resolver, o problema e na minha operadora
    eu estava lendo outros tópicos e observei que tinha um problema semelhante ao que estava acontecendo comigo referente a navegação, do nada apresentava umas engasgada louca quando passava pelo pf e vez por outra tinha que pedir para recarregar a pagina  realizei muitas configurações sem sucesso, e isso estava me bloqueando também o meu acesso externo
    Utilizei um modem roteador 4g e funcionou na hora, agora vou ligar para a net virtua e eles que se sevirem nos 30.
    Valeu a todos.



  • @ALDENIR:

    Boa tarde galera.
    Meu cenário e apenas te teste, mas com o objetivo de depois fazer uma vpn site to site e vejo que isso sera um problema, eu não possuo ip fixo real e meu modem não funcionou em bridge so em router mudei a regra conforme me recomendaram alterei minha porta do meu webadmin para uma porta mais alta e fui no modem e redirecionei para a porta desejada alterei a regra conforme o link que foi passado meu ddns esta batendo com o que esta no meu pf mas mesmo assim nem ao menos pingo eu uso esse maldito modem Humax HGB10R-02.
    E agora qual direção seguir ?

    Sei que vc já resolveu, mas complementando sua dúvida.
    Como seu moden não tem modo bridge, uma outra opção seria vc fazer uma DMZ no seu modem apontando para o IP do pfSense….isso tbm da certo.