XG-2758 1U re-install problems



  • I received a brand new XG-2758 from Netgate several months ago. I finally got around to turning it on and setting it up. When I went to upgrade the unit which was shipped with 2.3.4 to 2.4.2, the installer failed. From reading posts on this forum, it was suggested to try re-installing pfSense using the ADI image.

    With the USB plugged into one of the USB ports on the XG-2758, and connected via console port, the unit immediately boots into the “ADI Engineering Rangely Managemnt Console”. I am not given the option to boot from USB. In the ADI console, there is an update menu with the following option (send update.dat using Kermit protocol). Selecting this seems to do nothing - left running over night.

    Can anyone help me boot from the USB?
    Thanks.


  • Galactic Empire Netgate Administrator

    You’re connecting to the wrong console 🙂 There are two console ports, try the other one.

    https://www.netgate.com/docs/pfsense/xg-2758/connect-to-console.html



  • Thank you. I’ll give that a try. A couple of questions:

    1. Why would a factory installation of pfSense fail an upgrade on a Netgate appliance fail an upgrade? I have two other Netgate devices purchased at the same time (on 2.3.4) that failed the installation.

    1. What does the ADI acronym stand for?

    Thanks.


  • Galactic Empire Netgate Administrator

    Sure, let me know how it goes. To answer your questions:

    1.That’s a tough question to answer without more information. How did it fail exactly? You’re saying this failed at three appliances? How were they configured? You may have found a bug.

    2. ADI is one of our manufacturers.



  • The two other Netgate units were a SG-2440 and SG-4860. No packages were installed. It was literally the first action performed on the three firewall units.

    Using System Update from the GUI, with the 2.4.x as the stable branch it returned upgrade failed. I didn’t record the exact message. After the failure I was still able to access the GUI. At that point, I selected legacy general as the branch and attempted an upgrade to 2.3.5_1. Which succeeded. However, this remained in a reboot loop. I power cycled the unit and could not resolve the interface address.

    This is when I started to look for info on the forums and found that by re-installing the ADI image on the unit, things should work again.

    Thank you.


  • Netgate Administrator

    If the state of the install is in doubt for any reason reinstalling the firmware and restoring the config into it is always a safe option. If you have the firmware restore image and config file ready to go the process is pretty quick and painless.

    Steve



  • Thanks for the help. I was able to install pfSense from the ADI image.

    When connected to the console port, I’ve noticed that the boot up takes a long time. The unit appears to be looking for a network boot, presenting the message

    Intel Boot Agent GE v1.3.81
    Copyright 1997-2011, Intel Corporation
    PXE-E61: Media test failure, check cable
    PXE-MOF: Exiting Intel Boot Agent
    

    It repeats this 4 times and takes an extra 30 seconds to a minute.

    How do I get the unit to boot straight from the hard disk? What function key should I press? F12 is just boot options and when I select option 1 ‘AHCI SATA …’ it goes through those 4 network boot attempts.


  • Netgate

    There is coreboot update that prevents going to PXE first when an expansion card is installed.

    Do you have any expansion cards installed? What kind?

    If you have installed the Netgate_Coreboot_Upgrade package the coreboot status should be visible on the dashboard.

    If there is an update available I would install it.

    You might need to physically power the unit off and back on again to complete the upgrade so plan for that.



  • Thank you so much for the reply. The Netgate_Coreboot update worked. I have a factory-installed 4 port expansion card.

    On a separate point I noticed a push button on the back of my unit that isn’t mentioned anywhere. Is this a reboot button?


  • Netgate

    If functions the same as an ATX power button. If on, a quick press should trigger a shutdown (recommend just using the gui/console, but this is there too), a long press a hard power off (should be used only if necessary). If off a press should start it.



  • we are experiencing an issue where our XG-2758 worked fine and then all of a sudden started giving the error where it says it can’t find a device and check the cable.  The machine is locked in a constent boot up process and just loops.  I can boot into safe mode and that works but not sure how to reload pfsense from the command prompt? Can’t see, to get to the GUI in safe mode.  Is there a way to restore factory settings through the hardware? either a jumper or by pressing a button on the board while booting?


  • Galactic Empire Netgate Administrator

    Please contact our support so they can have a look. https://go.netgate.com/support/login


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy