Problem installing PFSENSE 1.2.2 in ALIX 2D3



  • I install several PFSense but this the first in embedded hardware. Everything works fine except the program freeze after a few seconds.
    In the serial I got:
    Configuring LAN interface…done.
    Configuring WAN interface...done.
    Configuring OPT interfaces...done.
    Configuring CARP interfaces...done.
    Starting OpenNTP time client...done.
    Configuring firewall......done.
    Starting webConfigurator...done.
    Starting DHCP service...done.
    Starting DNS forwarder...done.
    Setting up microcode and tx/rx offloading...done.
    Starting FTP helpers...done.
    Final filter pass......done.
    Generating RRD graphs...done.
    Starting DHCP service...done.
    and nothing else.

    A PC pinging 192.168.1.1 stop responding.
    The web config opens but dies after a few seconds.

    Originally I suspected of the CF but I already tried 4 different ones.
    I tried several older versions with similar results.
    I also syspected of the Alix board, buy I was able to install M0NO, IPcop, and linux that worked for hours.

    Any clue?
    Rgds
    Alberto



  • Doesn't make any sense to me. I've installed 1.2.2 on at least a half-dozen 2c3's.
    What's the BIOS version of the Alix? What image did you use? The serial should come up to the menu after you assign interfaces. You could try a 1.2 image and see if there is any difference.



  • Dotdash, thanks a lot for the answer.

    The BIOS version is 0.99
    I have different CF (all of them 2GB, but different brands)
    I tried 1.2RC2, 1.2, 1.2.1 and latest 1.2.2.
    In every case I can assign interfaces (no VLANs), only one LAN, WAN. only one PC with fixed IP conected to the LAN port.
    Rgds,
    Alberto



  • **SOLVED!!!

    After several revision finally I found the problem:  MFGPT workaround !!!

    If MFGPT workaround is set ON,  PFsense will freeze.

    Once I set it off, any version worked smoothly.

    Thanks a lot for all comments and sugestions.

    Alberto**



  • i have similar problem width 1.2.3 rc1 but i have no this option in BIOS



  • Update to the latest BIOS.


Log in to reply