PC xbox networking open NAT HELP NEEDED



  • I will start by saying that I have been able to get all of the consoles in the house (4 Xbox ones, a PS4, and a Nintendo Switch) on an open NAT by creating a static port for each system and enabling UPnP. In order to get the Xbox Ones to coexist, I had to manually select the port for it to use within each xbox's settings.

    Using the same method of creating a static IP and static port for my PC, I was able to get my NAT type for XBOX Networking (and Destiny 2) from a strict state to moderate.

    Ideally I would like to get my system's NAT type to open.

    Important Notes
    I do not have any manual port forward rules created.
    I used the wizard to create a basic traffic shaping rule prioritizing game traffic and de-prioritizing peer to peer connections.( I am aware that some games still use peer to peer connections for multiplayer.)
    Outbound NAT is Hybrid.



  • Hello,

    Try to separate your alias xboxgroup (do a alias for each one).
    Disable your rule prioritizing.
    Create ACL for UPnP

    It's works for me with 2 Xbox One, except for Warframe game.
    Test with this configuration (copy/paste from an other post)

    I have manies issues with Warframe on 2 Xbox on the same ISP (only 1 public IP address).
    In Warframe, I can't invite a friend to join me.
    At the best, only 1 Xbox can see the other player, launch a invit but an error message tell "The player is offline).

    All the network test on Xbox is OK : (Internet, Multiplayer and NAT Open)
    I try with other game (Rocket League and Warhammer Vermintide) without problem.

    I use PFsense 2.4.3-RELEASE (amd64)

    Firewall / NAT / Outbound

    Mode : Manual Outbound NAT

    Interface : WAN
    Source : Xbox1 (alias for 192.168.0.16)
    Port Source : any
    Destination : any
    Port Destination : anay
    NAT Address : WAN
    NAT Port : any
    Static Port : YES

    Interface : WAN
    Source : Xbox2 (alias for 192.168.0.17)
    Port Source : any
    Destination : any
    Port Destination : anay
    NAT Address : WAN
    NAT Port : any
    Static Port : YES

    Services / UPnP & NAT-PMP

    • Enable UPnP & NAT-PMP

    • Allow UPnP Port Mapping

    • Allow NAT-PMP Port Mapping

    • External Interface : WAN

    • Interface : LAN + loopback

    • ACL Entries : allow 1-65535 192.168.0.16 1-65535

    • ACL Entries : allow 1-65535 192.168.0.17 1-65535

    System / Advanced / Firewall & NAT

    • NAT Reflection mode for port forwards : Pure NAT
    • Enable NAT Reflection for 1:1 NAT
    • Enable automatic outbound NAT for Reflection

    Firewall / NAT / Port Forward

    Nothing, because I activate UPnP

    Actually, I must use the bad ISP-box only for Warframe ;-)

    Regards,

    Aym