DynDNS feature problem

  • Hi all,

    using Pfsense 1.2.1 with 1 Lan and 1 Wan ( cross cable to adsl modem )
    when using DynDNS feature, ( /services/Dynamic DNS ) my WAN private IP is send to DynDNS instead of my public IP

    any idea please ?

    thank you.

    //edited to be more precise.

  • Status | Interfaces
    shows correct assignment?
    Which DynDNS entry did you use (dynamic, static, custom)?

  • Thank you Jahonix, you touched something i forgot to notice, i've edited my first post

    in fact my pfsense Wan is linked to my adsl modem,

    ( Public IP ) <–-> [Adsl modem] ( <–--> ( ) [Pfsense Wan] ( ) [Pfsense Lan ]

    so the WAN IP is transmited to DynDNS instead of the Public IP


    DynDNS client feature is set to Dynamic

  • ;-)

    Your pfSense doesn't know about your actual WAN IP, thus it cannot promote it to DynDNS service.
    However, it correctly promotes what is known: it's WAN IP. That's not the LAN IP you pointed to earlier!

    Two possibilities:

    • let your modem do the DynDNS update itself (it knows the WAN IP)
    • (if at all possible) switch your modem to bridge mode and have pfSense do the PPPoE. This way it knows the WAN IP and can update your DynDNS settings correctly.

Log in to reply