Infuriating DNS Issue



  • So I have an APU device with 3 ports, my LAN port works fine no issues.  However, my kodi box which is directly plugged into the pfsense box on the second port can access internal resources but it can't get out to the internet.  I have VPN setup and have configured the firewall rules correctly, and setup the Manual NAT but nothing works.

    The funny thing is that this machine was working fine a week ago and I haven't changed anything in my setup.  I also tried to create a couple of wifi networks on my pfsense box and they have the same issue!

    For reference I use PIA and the wifi networks, LAN network, and Kodi network all have different subnets so maybe I don't have routing setup properly?

    The thing that gets me is that I even tried to reset everything to factory default and then re-setup both LAN and Kodi networks and it still doesn't work!?  Even without VPN and everything I still can't get out to the internet using that second ethernet port.

    I also checked the states of the port and it shows ESTABLISHED:ESTABLISHED and some FIN_WAIT:FIN_WAIT.

    The error I get when I try to browse google is DNS_PROBE.

    Any ideas?