OpenVPN TAP "Bridge DHCP" - Grayed out?



  • Hello forum members.

    Thank you all for the wonderful knowledge you have contributed to the forum.

    Iv learned quite a bit and finally setup a great pfsense box. Long time lurker first time poster.

    I am running the latest development build for pfsense "2.4.3-DEVELOPMENT (amd64)
    built on Wed Mar 14 16:48:00 CDT 2018 "

    I am messing around with Openvpn and wanted to create a TAP connection.

    The issue I am having is I can not click the "Bridge DHCP" checkbox.

    Has anyone else had this issue? I was wondering if pfsense 2.4.3 has disabled this for the time being until TAP connection issues could be resolved. I have searched the forums and cant seem to find a solution to my issue. I tried multiple browsers and disabled all ad blockers.

    I feel like I MUST be missing something.

    Thank you for your help



  • The IPv4 & IPv6 tunnel lines just above the "Bridge DHCP" toggle should be empty when running in TAP mode.  Those lines are for the TUN mode virtual networks.

    This snippet is from a live config on 2.4.3.

    ![Screen Shot 2018-03-15 at 12.41.34 AM.png](/public/imported_attachments/1/Screen Shot 2018-03-15 at 12.41.34 AM.png)
    ![Screen Shot 2018-03-15 at 12.41.34 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2018-03-15 at 12.41.34 AM.png_thumb)



  • Thank you bfeitell for your reply. I do have those fields blank but I am unable to check that box "Bridge DHCP" It just wont let me click it. It has a red circle when I move my mouse over it.

    Now that I see someone has it checked in 2.4.3, I will continue my pursuit and see what I may be missing.




  • It seems that for TAP mode, the server mode must be remote access, and not peer to peer.  My setup is for remote access.


  • LAYER 8 Netgate

    If that was the case the option would not be there.

    Is there a LAN interface configured to bridge with? Does that interface have a DHCP server defined?



  • This forum has a lot of good things that I have not known.
    Thanks for all the good forum.


Log in to reply