After trying the traffic shaper my VLANS are slow



  • Hi,

    I create diffrent VLANS with my pfSense and tryed different things with the Traffic Shaper. Then I deleted everything in the Traffic Shaper again. But now my Internet Connection in all my VLANS (except my Management VLAN) was slow. I have a 500 MBit synchron DSL connection, but in my VLANS I have only about 60MBit down and 150MBit up.
    When I make a new VLAN I get the full 500MBit.
    Is it possible that the traffic shaper crashes someting?



  • What exactly did you try out with the traffic shaper and what did you delete?  We'll need some more details there.

    Did you reset the firewall states after you deleted everything?



  • I used the wizard several times and tried to make some settings in traffic shaper "by interface" in my vlans. Than I deleted (disable shaper on interface) my setting again and the settings from the wizard. The section "by Queue" is empty. I also tried vlan prio and vlan prio set in the advanced firewall settings.
    I deleted all the firewall rules and make it New. The vlan prio is not set.



  • What were you looking to accomplish by using the traffic shaper wizard?  What interface(s) did you try to setup shaping for and which shaper did you use?  Have you deleted all settings that were applied once the shaper wizard was finished?  It sounds to me like not all shaper applied settings were properly undone/deleted.  However, we really need to know what you are trying to accomplish so we can guide you in the right direction.



  • I want to guarantee bandwith to the vlans with the traffic shaper. So I use it an the VLANS Interfaces. I also created limiters. But I deleted everything.
    There is nothing in the limiter an by queue section. And I klicked at all Interfaces  in the by Interface section. Nothing was enabled.



  • Now I have seen that the wizard has put a Firewall Rule in the Floating Section. I have deleted that entry but have the same problem.
    What else does the wizard do?



  • So did you use the wizard and tried to setup things manually using limiters at the same time?  Unfortunately I don't really know what the wizard all does since I've always setup traffic shaping manually.

    Did you follow the instructions I gave you in the other thread to try to accomplish what you mentioned above?  Those instructions only required creating limiters and queues, no need at all to use the traffic shaping wizard.

    Setting up traffic shaping properly is generally not trivial, and problems can arise easily if you just try things here and there and really aren't sure what you're doing.  If you have tried my steps in the other thread and things aren't working as expected, please report back and we can troubleshoot more from there.  As for troubleshooting what happened with the traffic shaping wizard, I'm afraid I can't be much more help. Hopefully someone else can jump in here to help figure that part out.



  • Now I have put pfsense to factory default and configured everything new.
    Unfortunately the Problem is the same. So the fault us not at the traffic shaper.
    I think I have now solved the problem. I have a Rule: block port xxx (pfsense Port), block RFC1918 Networks and in my allow rule I only accept the internet poRts.
    When I disabled all Firewall Rules and allow all Ports in the allow rule it is fast again.
    I have this rules since years and it newer slows my bandwidth.
    A few days ago I upgrade from 3.8.x to 2.4.2 RELEASE p1.
    Is it possible to downgrade again?


Log in to reply