Help: Many CP enabled and assigned to Interfaces but Only one CP its working



  • Hello, all PFSense enthusiasts and gurus.

    Attached it's my Interfaces and CP Service status screenshots, I've configured 6 Interfaces OPT1-OPT6 and enabled a CP for each one.

    I can access the CP on OPT1 but the others not.
    I've configured firewall rules for each OPT - Screenshot Attached

    I've tried many things but I haven't been able to get the 6 CP working in this PFSense box.

    can someone help me to get light on how to get all CP working?

    Thanks in advance.






  • Hi,

    No guru here  ;)
    Image 1 and 2 seem ok - nothing really to see actually.
    But rule 3 : WAN_DHCP as a gateway ? I haven't set 'nothing'.

    Do you see the login page ? Login User defined ? They have the 'rights' to visite the captive portal ?

    Added to that : after reading https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting : first issue : people mess up DNS.
    They leave the perfect DNS Resolver to switch to the DNS forwarder with exotic settings.
    Better : FreeRadius + MySQL. Or better is : make portal work with local user authorization, and build up from there.
    Then there are those with roque AP points.
    VLAN mess … (not your issue probably).
    DHCP server on each OPTx is ok ? (pool, etc)
    So, client receive an IP, Gateway and DNS (last 2 should be the IP of the OPTx network - so 192.168.y.1)
    Client can resolve  ;D

    Tour turn.



  • Thanks for your reply :)

    I see login page only for the first CP configured


  • Netgate



  • Thanks to all for yours replies

    I found out what was my BIG FAULT  :D

    CP are assigned ports increasing by 2

    8002, 8004,8006 and so on.

    connecting to:

    http://xxx.xxx.xxx.xxx:8002
    http://xxx.xxx.xxx.xxx:8004, etc

    Solved my problem