Как получать уведомления от pfsense при отключе



  • Всем привет! Подскажите, как получать уведомления на почту от pfsense и подключенного к нему APC когда отключают внешнее питание. (Services/UPS работает и данные об ИБП выводятся, SMTP Notifications настроен и ежедневные отчёты приходят). Всем кто откликнется и подскажет большой плюс в карму!



  • У меня NUT (UPS) настроен так:
    1.UPS Settings:
    Отмечено - Enable E-Mail notifications
    2. Advanced settings - Additional configuration lines for upsmon.conf
    вписать

    RUN_AS_USER root

    без этого письма через SSL  отправляться не будут:
    https://forum.pfsense.org/index.php?topic=115349.msg646251#msg646251

    3.System-Advanced-Notifications
    Настроен раздел E-Mail

    UPS шлет е-мейлы ока ждом чихе.



  • @pigbrother:

    У меня NUT (UPS) настроен так:
    1.UPS Settings:
    Отмечено - Enable E-Mail notifications
    2. Advanced settings - Additional configuration lines for upsmon.conf
    вписать

    RUN_AS_USER root

    без этого письма через SSL  отправляться не будут:
    https://forum.pfsense.org/index.php?topic=115349.msg646251#msg646251

    3.System-Advanced-Notifications
    Настроен раздел E-Mail

    UPS шлет е-мейлы ока ждом чихе.

    Вот начал получать уведомления, но чёт очкую вырубать питание для теста, у вас так же было когда заработало или это еще не всё?




  • У меня несколько иная проблема. Мелкая, но надоедливая.
    Задавал вопрос автору пакета, решения так и не нашли.
    https://forum.pfsense.org/index.php?topic=115349.msg745673#msg745673
    В остальном - все работает.

    У вас, судя по логам, ситуация хуже. Эти сообщения должны так же сыпаться в лог\консоль.
    Пробуйте поменять кабель. Можно написать автору (ссылка - выше)



  • @pigbrother:

    У меня несколько иная проблема. Мелкая, но надоедливая.
    Задавал вопрос автору пакета, решения так и не нашли.
    https://forum.pfsense.org/index.php?topic=115349.msg745673#msg745673
    В остальном - все работает.

    У вас, судя по логам, ситуация хуже. Эти сообщения должны так же сыпаться в лог\консоль.
    Пробуйте поменять кабель. Можно написать автору (ссылка - выше)

    Всё же я рискнул, пошёл и вырубил главный автомат, вся стойка запищала как шальная, но главное уведомление пришло! Всё работает, спасибо за подсказку, дело было всего-то в 1 команде.



  • дело было всего-то в 1 команде.
    Вы про
    RUN_AS_USER root

    Или о чем-то еще?

    пошёл и вырубил главный автомат, вся стойка запищала как шальная,
    Жестоко. Я просто вытаскивал сетевой кабель из конкретного UPS.