[SOLVED] Bug - High Availability Sync - Bootloop - 2.4.2 / 2.4.2_1



  • I configured 2 PFsense using two virtual machines over vSphere.

    All is ok, until by activating the High Availability Sync settings.

    When I apply this option, the system enter an infinity bootloop.

    –--

    • using version

    2.4.2-RELEASE (amd64)
    built on Mon Nov 20 08:12:56 CST 2017
    FreeBSD 11.1-RELEASE-p4

    I tried using the version 2.4.2_1 - The same problem occurs

    --

    Anyone have the same problem? Exist a solution for this?

    Thank you.


  • LAYER 8 Netgate

    Then you're doing it wrong. Not a bug.



  • I just activated the "Synchronize states" option, selected the dedicated Failover interface in the "Synchronize Interface" field, and filled in the primary PFSense IP in the "pfsync Synchronize Peer IP" field, clicked Save, after that it restarted and looped back up the server at all times.

    Where is the error that justifies bootloop?


  • LAYER 8 Netgate

    Don't know. Might be something in your VM config. Countless, literally countless pfsync configs out there that aren't seeing what you are.

    Unless you have limiters defined and are on an old version. Then you are hitting a fixed bug.



  • I'm doing an analysis here, but if anyone could help me, follow the Crash file.

    Thank you.

    Crash_Info.txt


  • Rebel Alliance Developer Netgate

    Looks like you have limiters. Disable pfsync until you upgrade to 2.4.3-RELEASE where that bug is fixed.

    It will be out very, very soon.



  • Hi Jimp!

    I did the upgrade of the 2 servers (main and backup) to the version:

    2.4.3-RC (amd64)
    built on Mon Mar 26 06:50:44 CDT 2018
    FreeBSD 11.1-RELEASE-p7

    After this update, I configured the "High Availability Sync" on both servers, only the "State Synchronization Settings (pfsync)" section, after that I configured the "Virtual IPs", even without problems. CARP works perfectly.

    However, a new problem arises when I activate the "Configuration Synchronization Settings (XMLRPC Sync)" option on the main server, I put IP, user and password and I go to "Save", no error occurs, but when I go to " Select options to sync "and select any option and go to "Save", I receive the message that I sent in the attachment.

    Can you have any idea what it might be?

    Thank you!






  • ??? :-[ :-\

    I found the problem. One server has access via HTTP and another HTTPS, this was the problem with synchronization.

    So I changed the two to HTTPS, normalized.

    Thanks all!


Log in to reply