Issues with school Chromebook and Sophos Web Gateway



  • I've got a fairly plain pfSense box running on an old HP desktop with a Q9300 and 8GB of RAM.  I ripped out the old GPU and stuck a PCI-E Broadcom dual-NIC into the x8 slot.  One problem I run into is with my children's school Chromebooks.  Only when they are using those Chromebooks with Sophos Web Gateway extensions do they have problems accessing Google Docs.  The Chrome browser forces them to reload constantly.  Other browsers on our home PCs don't do this, nor does it happen if they go to Google Docs without logging into Chrome (logging into the site instead of the browser).

    If I roll back to my Linksys router, there is no issue.  I can't tell where to start looking for problems, and I'm frustrated.  I'm not sure if I should look at a different PC to run this, to put it on a laptop, or find a different router distro.  Any suggestions?  Might I need to do Broadcom (bce) specific tuning?



  • Sophos Web Gateway extensions

    Can this be disabled just for testing purposes?  From your description, the problem is isolated to just the Chromebook in conjunction with pfSense.  What other pfSense packages do you have installed, if any?  Are you using a proxy like squid?



  • I thought it might be squid/squidproxy/lightsquid, so I uninstalled those packages and it still was present.  I reset the pfSense altogether and went back to my Linksys for a week, then reconfigured the system from scratch.  It worked for three days then the issue came up again.  Rebooting or resetting states does not help.

    The fact that even with Sophos enabled the Linksys works just fine is really annoying.



  • Anything in your firewall log when the problem happens?

    At this point I would wait until the problem returns and then do a packet capture and look at what's going on in Wireshark.


  • Netgate

    Yeah I looked at this sophos thing last night and could not find a description of what it actually does. I assume it establishes some sort of tunnel and forwards all chromebook traffic through it but I saw nothing that might help a firewall administrator that was experiencing problems actually try to fix it.



  • Am thinking incompatible HTTP, browser needs updating, does it happen to all sites, or only certain sites?

    Am also thinking MTU Ethernet packets being forcibly broken up but I've only seen this on PPPoE.



  • It only happens to Google Docs when the Sophos Web Agent is running.  This happens on the Chromebook itself, or when the kids log into the Chrome Browser with their school accounts.

    As far as using wireshark to capture packets, should I run ChromeOS in a VM? How do I get Wireshark to just capture the packets from the Chrome Browser or ChromeOS?