Dual Wan Problem



  • Hi I am new here and I have a problem with my setup. My Setup is I have 2 wan. I hide the 2 wan behind a router which is 192.168.2.1 and 192.168.3.1 consecutively. And my pfsense is 192.168.1.1.
    I configured load balancing perfectly well and my version is " 2.0-ALPHA-ALPHA
    built on Tue Dec 23 15:41:04 EST 2008
    FreeBSD 7.1-RC2 " So far I have no problem except my main concern.

    My main concern would be, supposed I want my http traffic to go to 192.168.3.1 gateway only. How can I can do it?

    Secondly, I have a program (actually a game online ) that uses a UDP port, what if I want that program to use only 192.168.2.1 gateway without turning off load balancing and not using sticky connection. Is there a way?



  • Use policy routing.
    (multiple rules that match your destination/port-description with different gateways)



  • Can you please specify how can policy routing be done in Alpha alpha. All I can see is port can be routed specifically. But how about http?



  • http is port 80



  • Thanks for the reply.
    For couple of weeks and a month I tried to use firewall rules in order to divert any http traffic such as youtube and http downloads into my other gateway but the results were the same, it would not use my other gateway's bandwidth.  Will somebody show me the correct settings for this to work? I've been testing this for months but with no avail. I tried to figure this out myself by using trial and error. So I'm seeking help with experts.
    Thank you and more Power and Luck to Pfsense Project
    Jack



  • You are going to have a hell of a time making this work with 2.0 Alpha.  As of the latest snapshot I tried, policy routing was broken and there have been no replies to any of the threads concerning it being broken.  If you do get this to work please let everyone know how and what snapshot you're working with to make it happen.



  • I did it. I used the Floating rule option for packet matching. Floating rule can be found at firewall rules tab. Many thanks to pfsense developers. Good Job.


Log in to reply