[ Solved ] Loopback & 2.4.3 Update


  • Galactic Empire

    ~~If anyone has an issue with syslogd not starting after the 2.4.3 update I think I've found an issue when using an IPv4 loopback address as the source address for syslog messages when sending them to a log server.

    I've raised a ticket after chatting with support and they are looking into it now.

    I can't start syslogd from the web page and it doesn't start from reboot, if I start it from the CLI it works fine till I clear the logs then it doesn't re-start.

    If I change the source address from an IPv4 Loopback to Default (any) everything works.~~

    Looks like its an issue with the loopback VIPs post boot :-

    [2.4.3-RELEASE][admin@pfsense]/root: ifconfig lo0
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=21 <performnud,auto_linklocal>groups: lo
    [2.4.3-RELEASE][admin@pfsense]/root:

    After going back into the virtual IPs and just hitting an apply to the defined vips :-

    [2.4.3-RELEASE][admin@pfsense]/root: ifconfig lo0
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x7
    inet6 2a02:xxxx:yyyy::1 prefixlen 128
    inet 127.0.0.1 netmask 0xff000000
    inet 172.16.0.1 netmask 0xffffffff
    nd6 options=21 <performnud,auto_linklocal>groups: lo
    [2.4.3-RELEASE][admin@pfsense]/root:

    https://redmine.pfsense.org/issues/8393 it's a bug.</performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast>