Unable to retrieve package information following update to 2.4.3



  • I have updated my pfsense installation from 2.4.2-1 to 2.4.3 (these have all been incremental updates from earlier versions) and pfsense now has a problem retrieving package information within Package Manager

    I should at this stage advise that I run multiple outbound VPN clients and DNS traffic is forced exclusively down one of the VPN Client (I appreciate its a bit of a chicken/egg situation but I have configured the client to connect by IP rather than DNS resolution).

    I am running unbound fully resolving with DNSSEC enabled

    The update proceeded normally (something like 97 packages being updated) but on rebooting and logging in via the GUI I was advised to make no configuration changes until the previously installed packages (eg Snort/pfblockerNG) were downloaded and reinstalled.

    This eventually timed out without downloading with a notice (under Available Packages) showing "Unable to retrieve package information".

    Logging in via the console and running option (13) "Update from Console" reported the following error message

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pkg-static: Repository pfSense-core load error: access repo file(/var/db/pkg/repo-pfSense-core.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_3_amd64-core/meta.txz: Network is unreachable
    repository pfSense-core has no meta file, using default settings
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_3_amd64-core/packagesite.txz: Network is unreachable
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    pkg-static: Repository pfSense load error: access repo file(/var/db/pkg/repo-pfSense.sqlite) failed: No such file or directory
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_3_amd64-pfSense_v2_4_3/meta.txz: Network is unreachable
    repository pfSense has no meta file, using default settings
    pkg-static: https://pkg.pfsense.org/pfSense_v2_4_3_amd64-pfSense_v2_4_3/packagesite.txz: Network is unreachable
    Unable to update repository pfSense
    Error updating repositories!

    DNS appears to be resolving fine for pfsense.org (but not for https://pkg.pfsense.org)

    casper@ghost ~ $ nslookup

    pfsense.org
    Server: 127.0.1.1
    Address: 127.0.1.1#53

    Non-authoritative answer:
    Name: pfsense.org
    Address: 208.123.73.69

    In attempting to resolve this issue I have tried restoring the configuration backup (taking immediately prior to commencing the upgrade) over the top of the update and when this did not work, undertook a vanilla install of 2.4.3 again with the configuration backup over the top again. I have also tried a vanilla install of 2.4.2 without success.

    My problem looks to be very similar to an earlier posting on this forum here

    https://forum.pfsense.org/index.php?topic=139276.0

    But the solutions suggested do not work for me

    I wonder if anyone can assist (or if mods consider appropriate) perhaps move this topic to the DNS forum ?

    Cheers



  • As someone pointed out to me, pkg.pfsense.org does not use a DNS A[ddress] record, but a SRV record.  So a default nslookup won't return anything as nslookup defaults to A record queries.

    However the error messages suggest a network reachability issue, rather than a DNS lookup failure.  Does your default route make sense?  Can you ping files00.netgate.com or files01.netgate.com?



  • I have spent the last two weeks, trying to upgrade pfsense and trying to load packages keep getting errors - reinstall pfsense a couple of times basically pulling out my hair.

    Here is the fixed

    login into pfsense using ssh, when the console loads choose option 8
    the shell command and enter this text  pkg upgrade pkg

    click enter after it finishes

    choose option 13 from the same console after that you can install any package that you wish.
    the package manager is broken in 2.4.2 , 2.4.2_1 and 2.4.3



  • @nattygreg thanks very much for workaround, fixed my install.