Port forwarding for Exchange server



  • Dear All,

    This is my first post on this forum. Today I wanted to replace my Edgerouter firewall with a pfsense box. I have behind the firewall in the LAN zone an Exchange 2016 server as a VM. For the Exchange server I forward port 25, 80 and 443 to my mailserver. I have iPad, iPhone setup with my mailbox. I even use for my computer in the LAN zone the external FQN name. It's easier for autodiscovery with a certificate. Everything works great with the Edgerouter which has port forwarding set.

    Today I set up the pfsense firewall with the same port forwarding rules. Port 80 and 443 worked fine. I could connect with Outlook or iPad to the email. However port forwarding rule for port 25 didn't work. I see in the firewall log pass entries for port 25 with the destination IP for my mailserver. However actually email were never delivered to my mailserver. I verified that with the Get-MessageTrackingslogs cmdlet. Mails stopped delivery when I took the pfsense live. I tried several things, but nothing helps.

    I set up up other port forwarding entries for my Synology and they worked fine too. Just not port 25.

    I removed the pfsense from the network and put in the Edgerouter in production again. After that the mails arrived again at my Exchange server.

    I'm just curious what is so special with port 25 than the other ports I forwarded successfully.

    Any idea?

    Thanks,


  • LAYER 8 Netgate



  • Thanks - the problem was not a a wrong configuration of the NAT or firewall rule. I had to disable DNS resolver and afte that mails were flowing instantly.



  • How would disabling the resolver accomplish that??


Log in to reply