DHCP Client Option with Mac Address



  • Hello, I started using pfsense for a few weeks now and I'm having my first blocking point when configuring advanced DHCP Client Configuration.
    In order for my box to work with my FAI I need to configure the following DHCP options: 61 Client Identifier, 77 User Class information, 60 Vendor Class identifier.
    Option 77 and 60 looks fine but option 61 looking at the packet it doesn"t appear. I need to specify the mac address value in this field

    This is my config in the send option field:
    dhcp-class-identifier "sagem", user-class "+FSVDSL_livebox.Internet.softathome.Livebox3", dhcp-client-identifier {mac_addr_hexU:}:90:XX:XX:XX:XX:b0
    ![](http://pfsense dhcp option.PNG)

    See attached screenshot for packet capture
    ![](http://pfsense DHCP discover.PNG)

    ![pfsense DHCP discover.PNG](/public/imported_attachments/1/pfsense DHCP discover.PNG)
    ![pfsense DHCP discover.PNG_thumb](/public/imported_attachments/1/pfsense DHCP discover.PNG_thumb)
    ![pfsense dhcp option.PNG](/public/imported_attachments/1/pfsense dhcp option.PNG)
    ![pfsense dhcp option.PNG_thumb](/public/imported_attachments/1/pfsense dhcp option.PNG_thumb)
    ![mybox DHCP discover.PNG](/public/imported_attachments/1/mybox DHCP discover.PNG)
    ![mybox DHCP discover.PNG_thumb](/public/imported_attachments/1/mybox DHCP discover.PNG_thumb)



  • Ok I found the solution the parameters need to be in the correct order  60, 61, 77

    dhcp-class-identifier "sagem", dhcp-client-identifier 1:90:xx:xx:xx:xx:b0, user-class "'FSVDSL_livebox.MLTV.softathome.Livebox4"