Wan interface up all rules stop working



  • Hi Folks,

    I am a newbie here and wanted to run this by everyone. I have 5 interfaces on my pfsense setup. One is the wan interface the rest are separate subnets. After creating a few firewall rules between these subnets I realized that they all worked perfectly when the Wan interface was brought down, but as soon as the wan interface was up they no longer worked. The only rule on the Wan interface is the openvpn allow connection.

    Also the first subnet can access the internet but the others cannot even though NAT outbound has the auto generated rules for all of them.

    I realise that I will have to provide more details but wanted to know if something stuck out right away that I may have missed.

    cheers


  • Netgate Administrator

    What firewall rules do you have on those other interfaces?

    Do you have multiple gateways defined? An OpenVPN gateway perhaps?

    The most likely scenario is that you have rules with the WAN gateway set that are only applied when it is UP.

    Steve



  • Hi Steve,

    For troubleshooting purposes I left only basic rules any any, and ICMP echo requests. Only one gateway defined for the WAN interface. The only rule on the WAN is the openvpn allowing connections in. Again it is when the WAN interface is UP that all the rules stop working.

    Thanks again


  • Netgate Administrator

    What is your WAN interface? How is it connected?

    Does it have a private IP that is conflicting with the internal subnets perhaps?

    Can we see some screenshots of you rules? The routing table from Diag > Routes might also be revealing here.

    Steve


Log in to reply