Custom Dynamic DNS - False notifications



  • I have 3 DynDNS entries, 2 of them are configured as custom and the last one is GoDaddy.

    Even if there was no address change I've received 2 email notifications saying

    DynDNS updated IP Address on WAN (igb0) to a.b.c.d

    As it shown in the log it was no address change at all.

    Here is the log:

    Apr 2 01:01:15	php-cgi		notify_monitor.php: Message sent to xxxxx@gmail.com OK
    Apr 2 01:01:05	php-cgi		rc.dyndns.update: phpDynDNS (xxx.xxx.info): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.
    Apr 2 01:01:04	php-cgi		notify_monitor.php: Message sent to xxxxx@gmail.com OK
    Apr 2 01:01:04	php-cgi		rc.dyndns.update: phpDynDNS (): (Success) IP Address Updated Successfully!
    Apr 2 01:01:04	php-cgi		rc.dyndns.update: phpDynDNS: updating cache file /conf/dyndns_wancustom''1.cache: a.b.c.d
    Apr 2 01:01:02	php-cgi		rc.dyndns.update: phpDynDNS (): (Success) IP Address Updated Successfully!
    Apr 2 01:01:02	php-cgi		rc.dyndns.update: phpDynDNS: updating cache file /conf/dyndns_wancustom''0.cache: a.b.c.d
    
    

    My understanding that the false notifications were triggered by the two custom entries. Is this related to the way how custom provider is implemented?



  • Your log shows 2 DynDNS updates of the custom entries and the other one was not changed, though.
    The DynDNS updates seem to be triggered by the scheduled DynDNS check, not by an IP change.

    That seems to me like the GoDaddy entry was updated before when the IP has changed, but the customs were not.
    Are all the entries set on the same interface?

    I'm looking for a way to disable the notification on DynDNS update. Do you incidentally know how to?