SG-1000 loses LAN when upgrading to 2.4.3

  • I just bought an SG-1000, successfully configured with wizard, accessed Internet, and saw a firmware update to 2.4.3 was available in the Dashboard.
    I initially tried to upgrade (download and start), but upgrade failed.
    I rebooted the hardware and tried again. After reboot, I upgraded successfully (as seen in the upgrade messages), but now I have no LAN connection after auto restart from the upgrade.
    Even a hardware reboot after about 20 minutes of no DHCP was unsuccessful in restoring DHCP/LAN connectivity.
    Is this problem common? Will I need to re-flash back to the original 2.4.2 version on the SG-1000 when shipped from netgate and ignore version 2.4.3, as unstable?
    Any suggestions would be appreciated. Sorry, no logs as I can no longer access the SG-1000 with the LAN connection. Before I go further, I wanted to reach out to see what is the best direction to take to minimize time on this matter.

  • Rebel Alliance Developer Netgate

    That isn't a known issue as far as I'm aware. It's possible your setup has something unique that is tripping it up, however.

    Are you able to reach the GUI at all? Or the console?

    If you can get to the console, start a shell and run "etherswitchcfg", what does it show?

    And check the logs from the console, see if anything stands out (clog /var/log/system.log)

    If you must reinstall, try reinstalling 2.4.3 first. If that still doesn't work, then back down to 2.4.2-p1.

  • Jimp: Thanks for your reply. I can't access via GUI, as I do not get a DHCP address or even when set to static IP with last known address, no GUI. Below is a snapshot of the console with the commands you suggested. Not sure why the commands are not being found. I must admit, I am new at the command interface, so most likely something I have done wrong.

    ![Screen Shot 2018-04-02 at 15.51.44.png](/public/imported_attachments/1/Screen Shot 2018-04-02 at 15.51.44.png)
    ![Screen Shot 2018-04-02 at 15.51.44.png_thumb](/public/imported_attachments/1/Screen Shot 2018-04-02 at 15.51.44.png_thumb)

  • jimp was asking you to access the console on the SG-1000 and then run those commands.  You seem to have opened a console window on your Mac and run the commands there.

Log in to reply