2.4.3 RELEASE UPGRADE ?



  • I am not sure if the community at large was able to successfully do a 2.4.3 upgrade….
    So here is the poll  ;D



  • SG-2440. Bricked. Two red lights and no console. So that's a nope!


  • Rebel Alliance Developer Netgate

    @braxtoncook:

    SG-2440. Bricked. Two red lights and no console. So that's a nope!

    Red lights on there is a hardware issue, not related at all to 2.4.3, but bad timing. Open a ticket with support and we can help you with that.



  • Updated an APU with the CE version.

    Does not boot (see two threads related to the issue).



  • Upgraded my pfSense on my APU2 to 2.4.3 without a problem.  From my iPhone.  Over IPSEC VPN tunnel.  Probably wasn't the best idea, but I was curious to see if it would work or not.


  • Rebel Alliance Developer Netgate

    I have an APU (first gen) here and it runs 2.4.3 and 2.4.4 just fine. Most likely you have some hardware-specific issue that is not directly related to pfSense. Keep that in the threads that already exist for it.



  • Upgraded just fine for me too



  • My SG-2440 running 2.4.2_1 downloaded and claimed to have installed 2.4.3 (fetched all 78-ish packages, installed them, declared success, and rebooted on its own) but never came back from the "Rebooting; this page will reload in 90 seconds" page.  The lights are all green, but zero responses via the web configurator, and none of the actual functionality (routing, DHCP, DNS, etc) came back either.  Basically the same behavior as described in the "bricked sg-4860" thread – it said it had finished successfully, gave me a "done" and rebooted on its own, then nothing.

    Tried power cycling, the green lights came up quickly, but still no responses.

    I've dug out an old Belkin switch to put in its place, which is how I'm typing this now (and downloading the .img for a USB stick).  I don't have an 40-meter USB cable to connect to the console port, so buying a USB-b cable and digging the 2440 out and bringing it to the computer will be tomorrow's project.



  • and my vote goes to "Yes" !  :)



  • Upgrade from 2.4.2  to 2.4.3  via UI failed completely.
    I now have a largely bricked device.

    Logging in as admin,  gives 'core dumped' message at top of menu.

    Attempting to "Reset to Factory Default" (Option 4)  results in "Core Dump" message

    Downloaded the  CE memstick and inserted.    It is not auto-detected therefore not able to recover

    Examination of the  /scripts directory shows it's empty.  I suspect this is a big problem given the 2.4.3 CE USB has a lot of entries.

    Request instructions about how to proceed.    I'd really rather not trash the SG-2220.      This is my first and LAST time loading before update 1 is released

    Please help



  • As additional info,  I've spotted

    /usr/local/etc/rd.d/microcode_update:  exec_format_error

    Oops!


Log in to reply