Updating



  • Since the new update of PfSense it can not update?

    example on the front main page:

    2.4.3-RELEASE (amd64)
    built on Mon Mar 26 18:02:04 CDT 2018
    FreeBSD 11.1-RELEASE-p7

    Unable to check for updates

    –----
    Installed Packages 
    No packages installed.

    When I check for packages it says Unable to retrieve package information.

    I haven't touched anything for this to happen but it started just on the new update to 2.4.3 ?

    I know im being blocked some how but I haven't touched it so im not sure what happened?

    How do I get out of this one ?

    Many thanks to any help in advance ;)



  • Same here. On version 2.3.4-RELEASE

    Unable to update via GUI.

    Tried option 13 in the console.

    Number of packages to be installed: 27
    Number of packages to be upgraded: 86
    Number of packages to be reinstalled: 38

    The process will require 45 MiB more space.
    109 MiB to be downloaded.

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) Y
    Aborting…

    Unlocking package pkg... done.
    *** Welcome to pfSense 2.3.4-RELEASE (amd64 full-install) on pfSense ***

    What do we do?



  • @anttechs search for one of the many recent posts talking about being unable to update packages to find how to manually bootstrap the package process.

    @pwilliz did you try with at lower case "y"?  It could be that it was coded to only proceed if the input matched just the lower case y suggested and otherwise aborts.  As for the GUI, it can only show you the first phase of an update, until the beginning of the initial reboot.  In 2.4.3, alot goes on after that and may take a while depending on your hardware and packages.  Generally a lot of patience is recommended using the GUI route.  Similarly for an SSH initiated upgrade.  Doing the upgrades from the console, you can watch all the progress.  I also found for  the 2.4.3 upgrade I had to do an additional reboot to get my package (NUT) working properly.


Log in to reply