RuleError:There were errors loading the rules: /tmp/rules.debug:18: cannot alloc



  • Hi All

    Im pretty new to PFsense at the moment but just saw these flagging up from today (been running since a week ago now).

    I have 5 rules in total including the 2 default ones from PFSense and GB's of memory available.

    Any idea what this is about?

    There were error(s) loading the rules: /tmp/rules.debug:18: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [18]: table <bogonsv6> persist file "/etc/bogonsv6"
    @ 2018-04-02 05:34:45
    There were error(s) loading the rules: /tmp/rules.debug:18: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [18]: table <bogonsv6> persist file "/etc/bogonsv6"
    @ 2018-04-03 14:13:19
    There were error(s) loading the rules: /tmp/rules.debug:18: cannot define table bogonsv6: Cannot allocate memory - The line in question reads [18]: table <bogonsv6> persist file "/etc/bogonsv6"
    @ 2018-04-03 14:13:36



  • I have the same problem on 4 pfsense servers, yesterday reinstall one and today 3 more shows the errors!!!! I suspect it's a hacking problem….

    Any can help us??

    Thanks.



  • That's not a hacking problem, it's an upgrade glitch.
    Several others reported this already so watch the forum and read what other threads come up with.


  • Netgate

    Not hacking ffs.

    Do a forum search.

    Increase the Firewall Maximum Table Entries size to 400000 in System > Advanced, Firewall & NAT



  • Thanks Derelict, I make a search but don´t see the answer, sorry for that…

    Again thanks to all.

    Greetings...



  • Not hacking ffs.

    No, I'm pretty sure it's hacking.  It's always hacking.  ;D



  • Thanks all, il give that a try and see if it helps.



  • @Derelict:

    Not hacking ffs.

    Do a forum search.

    Increase the Firewall Maximum Table Entries size to 400000 in System > Advanced, Firewall & NAT

    It Works Well!!!!!!Thanks  :D



  • mine is on default
    Maximum number of connections to hold in the firewall state table.
    Note: Leave this blank for the default. On this system the default size is: 4909000

    should I put more than that?


  • Netgate

    It is not the Firewall Maximum States entry it is the Firewall Maximum Table Entries setting. Set it to 400000.



  • Jeej fixed my problem!!!!



  • @Derelict:

    Not hacking ffs.

    Do a forum search.

    Increase the Firewall Maximum Table Entries size to 400000 in System > Advanced, Firewall & NAT

    This solved it for me after losing NAT port forwarding during a reboot this morning.  Thanks!



  • @Derelict:

    Not hacking ffs.

    Do a forum search.

    Increase the Firewall Maximum Table Entries size to 400000 in System > Advanced, Firewall & NAT

    =================================

    Post increasing the Firewall Maximum Table Entries size to 400000 , all rules started working.. Thanks buddy.. i helped a lot..



  • Thanks so much for the input!  the changing of the 'max table entries' size to 400k did the trick!!



  • Just wanted to say that I got the same message today, although my system says that its default is 6 million entries.


  • Netgate

    Set it to 400000.



  • Worked perfectly, thank you!