Changed DNS to 1.1.1.1 in System>General Setup>DNS. IPCONFIG now show my Gateway



  • I'm a n00b when it comes to DNS. Usually, when I want to change a DNS, I just manually do it in the network adapter, so I apologize if this is a trivial question.

    I changed the default DNS in System>General Setup> DNS to 1.1.1.1 and 1.0.0.1 and unchecked DNS Server Override.

    Question 1:
    When I tested my desktop PC with ipconfig /all, it showed an odd string for the DNS - After research, I came to the conclusion it had something to do with IPv6, so I disabled that in my network adapter's settings. Do I need to disable IPv6? Or is it okay? If IPv6 is enabled here is what I see:
    DNS Servers . . . . . . . . . . . : 2601:546:8201:40e1:225:90ff:fe30:a459
                                          192.168.1.1

    Question 2:
    When I disable IPv6 on my computer, in ipconfig /all I only get my default gateway as the dns server- 192.168.1.1. Is this okay? I find it odd that it's not handing out 1.1.1.1 or 1.0.0.1 as the DNS.

    Sorry for the stupid question, I did A LOT of searching and could not find a straight answer.

    Thanks again.



  • @tlm4594:

    ipconfig /all I only get my default gateway as the dns server- 192.168.1.1. Is this okay? I find it odd that it's not handing out 1.1.1.1 or 1.0.0.1 as the DNS.

    This is normal and standard.

    PFsense, like many other firewall and router boxes runs a local DNS service, which in between other things CACHES DNS resolutions, so repeat DNS requests don't have to get out to the Internet, which takes time, to resolve, the local DNS service answers within a millisecond.

    Now you can certainly force PFsense to hand you the 1.1.1.1, if the extra time it requires to execute your requests is intentional.


Log in to reply