Strange case of the disappearing anti-lockout rule



  • Greetings,

    I recently installed pfsense on a custom box that I built and it has thus far been running smoothly until today. I rebooted it several times as I was doing some testing, and the web gui stopped working. I traced the problem down to my firewall rules, and it seemed as though my anti-lockout rules have gone missing (allow traffic on ports 80 and 22). They are not present under firewall->rules->interface

    Aside from rebooting the box, I did not make any other changes to it, so I'm a bit puzzled as to how the web gui/ssh went from fully functional to me now needing to write specific exception rules for them.

    Incidentally, I've also had some issues with pfsense complaining that it's having trouble loading bogon rules as referenced in this post. Perhaps the two are related?

    https://www.reddit.com/r/PFSENSE/comments/88ry96/there_were_errors_loading_the_rules/

    Thanks in advance.


  • LAYER 8 Global Moderator

    If there were problems loading rules then yeah your going to have a bad day.

    Yes increase your table limit from the default 200000 to 400000 its all over the forums..


  • Banned

    You didn't configure a gateway on that LAN interface, did you? If you do pfSense will consider it as a WAN interface and stop applying the anti-lockout rule.



  • Yeah I increased the max firewall table entries to 5000000. Haven't seen any more issues since. What's weird is that I ran a pfsense VM for months prior to building one on metal and this never came up. My vm only had 2gb whereas my hardware firewall has 4gb.

    How do I restore the actual anti lockout rule? Right now I have two rules that allow port 80 and port 22.


  • LAYER 8 Global Moderator

    once you rules load correctly it should be there. 5,000,000 is a bit drastic.. 400,000 should be more than enough and is going to be the new default.

    You should always be able to cycle if antilock is enabled disabled under

    System / Advanced / Admin Access


Log in to reply