Problema com a versão do pfsense 2.4.3 o squid não funciona



  • :-[BOM  DIA PESSOA, POR FAVOR ME AJUDEM

    EU ATUALIZEI A VERSÃO DO PFSENSE DE 2.3.4 PARA 2.4.1,  MAS AGORA O SQUID E O SQUIDGUARD PAROU DE FUNCIONAR

    MINHAS REGRAS DO SQUID É BLOQUEAR TUDO E LIBERAR SOMENTE O NECESSARIO,

    por favor me ajudem, se por acaso alguem passou por isso me ajudem,  tenho acompanhado o forum na tualização desta versão e por ter dados alguns problemas  fiquei com receio de atualizar, mas como eu vi que nao havia mais reclamações decidir instalar pois um firewall atualizado vc sente mais protegido, mas me deparei com esse problema, sei que é correria para todo mundo, mas fiquei das  das  13hs  até as 21hs  na empresa e não conseguir resolver o problema.



  • Bom dia Francisco,

    já passei por isso umas duas vezes, acredito que tenha até tópico meu aqui no fórum solicitando ajuda também.

    A solução minha foi remover e instalar novamente.

    Se eu não me engano a remoção primeira foi do squidGuard, ai reiniciei o serviço do squid, se não voltar você reinstala o squid novamente.

    Na época ele pegou novamente minhas configurações, se não você salva em algum canto.

    Lembro-lhe faça seus backups antes, cada situação tem suas peculiaridades.

    Mas n foi um bixo de sete cabeça não.



  • Franciso, tudo certo?

    Conseguiste resolver teu problema? Estou com a mesma coisa aqui.



  • Vocês não fazem homologação antes de atualizar de uma versão par outra?



  • Sim Tomas sabichão, foi feito Teste e o problema não estava na versão nem nada.
    Caso alguém precise de AJUDA PRA RESOLVER O PROBLEMA, segue o que estava ocorrendo aqui.

    Erro: No valid signing SSL certificate configured for HTTP_port xxx.xxx.xxx.xxx:3128 Squid Cache

    Solução: O certificado criado e aplicado no Squid para o MITM estava com erro. Simplesmente criei um novo certificado e configurei ele no Squid. Após isso os serviços normalizaram.

    Abraços.



  • Pessoal eu consegui,  só que eu tive  que reinstalar do zero,e claro antes de atualizar eu fiz um backup, mas na atualização estava bloqueando tudo e não conseguir resolver de jeito nenhum, minha solução rapida foi reintalar do zero, e restaurar o backup, reinstalando os pacotes diagnostic, Package Functions, reinstall packages



  • Pessoal uso proxy não transparente, e usava a versão 2.3.4,  mas depois que atualizei a versão o recaptcha parou de funcionar, e estou tendo problemas com alguns sites como o sintegra.gov.br, https://www.edponline.com.br/para-sua-casa?ReturnUrl=%2Fservicos%2Fextrato-de-contas pararam de funcionar alguem pode me ajudar



  • @Francisco:

    Pessoal uso proxy não transparente, e usava a versão 2.3.4,  mas depois que atualizei a versão o recaptcha parou de funcionar, e estou tendo problemas com alguns sites como o sintegra.gov.br, https://www.edponline.com.br/para-sua-casa?ReturnUrl=%2Fservicos%2Fextrato-de-contas pararam de funcionar alguem pode me ajudar

    Alguns sites não passam por proxy, infelizmente. tente o e2guardian para ver se com ele passa o site ou configure o wpad para definir que sites passam ou não pelo proxy.



  • Bom dia Senhores,

    Por incrível que pareça aconteceu ontem algo parecido, como eu sempre deixo um proxy reserva na manga só troquei o ip e fui pra casa…

    Chegando hoje pela manhã fui verificar o log e vi que não era uma coisa de sete cabeça haahah, simplesmente estourou o espaço em disco com o cache, pois eu fiz atualização do sistema e só de sistema ele ta pegando 39GB como o ssd é pequeno logo não aguentou e arriou...

    Cada situação tem suas peculiaridades, deixo aqui a minha derre pente ajuda em alguma coisa.

    Para resolver a situação simplesmente limpei o cache e o serviços voltaram. (squid, squidguard e lightsquid_web).

    abraços!



  • alem das configurações que encontrei no forum, tive que adicionar essas listas ni firewall criando um alias https://code.google.com/archive/p/recaptcha/wikis/FirewallsAndRecaptcha.wiki

    e colocar esses dominios no squidguard
    google-analytics.com www.google.com gstatic.com, espero que ajude!



  • Boa tarde passei por isso esses dias observei que as regras de redirecionamento do proxy das porta 3128 e 3129 não ocorria foi só desativar o proxy transparente salvar e depois ativar de novo e salvar novamente que as regras funcionaram. isso ocorreu depois que rodeio update para 2.4.3-RELEASE-p1