Squidguard not blocking sites.



  • I'm using PFSense version 1.2.2 built on Thu Jan 8 22:30:24 EST 2009
    Squidguard version 1.3-1
    Squid version Stable 2.6.21_07 platform: 1.2.1 (currently running Squid3 3.0.8_06, just to try it)

    I have the following url in the Blacklist URL field: http://www.shallalist.de/Downloads/shallalist.tar.gz, I click upload, wait a few minutes and I am able to see all the catagories.  I select the ones I want to deny (porn, nudity, etc)m run a test, and the sites never get blocked.



  • Look squidGuard demo below



  • after upgrade to 1.2.2 same problem, don´t work



  • Interestingly I have a similar problem.  Mine used to work just fine then without any changes I'm aware of (except maybe adding a few more items to some of the blocklists) squidGuard has stopped functioning (and sadly I've no idea when, other than some time in the last couple of months).  I only confirmed it this morning so haven't done any troubleshooting to try to narrow down the problem.



  • @dvserg:

    Look squidGuard demo below

    I have followed your instructions, still not blocking anything.



  • Don't forget to click the Apply-Button.



  • no. this problem different cause.

    your client browser connection properties proxy server adress input your pfsense lan adress and port (3128)

    now block squidguard.



  • @bahattin:

    no. this problem different cause.

    your client browser connection properties proxy server adress input your pfsense lan adress and port (3128)

    now block squidguard.

    I actually changed the proxy port to 800, and I think Squidguard didn't like that.  I changed it back to 3128 and I beleive Squidguard is working, I will have to do more test.



  • SG filter only and not depends from proxy port This is squid option.



  • Mine is different. It works really great but i dont want to save all sites visited http and https. How to get rid of this? I dont want them to save the http/https logs .. I dont have enough space…

    thanks
    jigp of davao



  • My pfsense also can't block sites, if i active ACL. I wanna set 1 ACL base time to block Friendster and Facebook , but if i set ACL other site not blocked, example porn (always block alltime). Already try create 2 ACL, still doesn't work. Now my Facebook and Friendster can't be block by time.

    ACL 1 setting block all porn, but give default all access = allow with base all day.
    ACL 2 setting block FB & FS, but give default all access = allow with base on time.

    if i don't use ACL i can't block by category, but i want to block base time too, please advise.
    Other question, why i have to restart Pfsense if my internet being down and up again? so if i don't restart pfsense after my internet being down and up again, client can't access the internet.

    thx



  • @Shinatama:

    My pfsense also can't block sites, if i active ACL. I wanna set 1 ACL base time to block Friendster and Facebook , but if i set ACL other site not blocked, example porn (always block alltime). Already try create 2 ACL, still doesn't work. Now my Facebook and Friendster can't be block by time.

    ACL 1 setting block all porn, but give default all access = allow with base all day.
    ACL 2 setting block FB & FS, but give default all access = allow with base on time.

    if i don't use ACL i can't block by category, but i want to block base time too, please advise.

    Possible view you SG config ?



  • @dvserg:

    @Shinatama:

    My pfsense also can't block sites, if i active ACL. I wanna set 1 ACL base time to block Friendster and Facebook , but if i set ACL other site not blocked, example porn (always block alltime). Already try create 2 ACL, still doesn't work. Now my Facebook and Friendster can't be block by time.

    ACL 1 setting block all porn, but give default all access = allow with base all day.
    ACL 2 setting block FB & FS, but give default all access = allow with base on time.

    if i don't use ACL i can't block by category, but i want to block base time too, please advise.

    Possible view you SG config ?

    it seem the problem is the ip address, cause i'm set the ip client is 192.168.0.0./24 for all ACL rule. so it seem it read only 1rst rule cause of it. i've resolved the problem, now i'm using 1 ACL rule base on time, block FB & FS, and block Porn all time. Just set deny on right and left, in acl rule. But hope this will upgrade so i can use multiple acl rule…

    thx for you help..


Log in to reply