Trying to setup PPPoE server on Pfsense box with FreeRadius authentication.



  • Hi Guys,

    I try to get my Pfsense box to be both a FreeRadius and PPPoE server at the same time.
    I created an interface  in FreeRadius and assigned the ip address 172.16.15.1 to it. created a user with bandwidth limitations and a NAS/Client with IP address 172.16.15.2(which is also the IP address of the PPPoE server). I then connect a router to the appropriate LAN port on the Pfsense, with the router's WAN configured as PPPoe client, with the credentials configured as a user in FreeRadius. It does not connect. The Status/System Logs is showing "Ignoring request to auth address 172.16.15.1 port 1812 bound to server default from unknown client 172.16.15.1 port 54795 proto udp". When i run "radiusd -X" from the command prompt I get "Failed binding to auth address 172.16.15.1 port 1812 bound to server default: Address already in use
    /usr/local/etc/raddb/sites-enabled/default[2]: Error binding to port for 172.16.15.1 port 1812".

    If I disable radius authentication, and use local user on the PPPoE server, the router connects. Any ideas ?



  • I forgot to mention  that the box is running Pfsense ver 2.3.4 I386.

    No one tried this before?



  • Still trying to get this to work. Using the utility "radtest", I noted that the radius server seem to be just listening on the WAN port of the box, eventhough I configured Freeradius to listen on a LAN port. Anyone? Need more info?


Log in to reply