Embedded upgrade feedback



  • I've been playing with tweaking a 1.2.2 embedded image for Alix installs. I've got a test image resized to 1 GB and tried the embedded update to 2.0-Alpha-alpha just to see what happens. After a long wait the box rebooted and couldn't find a kernel. I tried two embedded update files, 20090105-1640 and 20090119-1608.
    I know this is not supported, I'm just reporting the results of my testing.

    EDIT: This also happens trying to update 1.2.2 to a 1.2.3 snapshot. Tried using the webgui and also using the console method (local file on a USB drive).
    It bootstraps and I get-
    Loading /boot/defaults/loader.conf
    Unable to load a kernel!

    can't load 'kernel'

    EDIT: Autoupdate on embedded fills /tmp and exits with a corrupt image error. Switching the platform, rebooting, and auto-updating, then switching back to embedded and rebooting again seems to work.



  • Oops. Just upgraded an Alix embedded from 1.2.2-RC1 with pfSense-Embedded-Update-1.2.3-20090307-1252.tgz and it never returned.

    Wish I'd read this post first ;)  Now I have to dig the mobo out of that case, pull the CF etc., etc.


Log in to reply