Problem with saving configuration



  • Hello, I have a problem with option Move configuration file to removable device. I attach flash drive, boot PC and load pfsense CD. After configuration I cannot save the configuration to flash drive or floppy drive. Following error appears.

    I tried to another PC, and there is the same problem. Can anyone tell me where can be the problem?
    Thank you in advance.



  • I suspect the device you use to save your config file needs to have a FreeBSD file system on it. Most USB sticks seem to come with FAT file system (not FreeBSD). I haven't used floppies for a long time but I suspect they also come per-formatted with FAT or come unformatted.

    I expect if you search the forum or the pfSense Wiki you'll find a recipe for appropriate formatting. If you can't find one there its worth looking in the m0n0wall documentation - follow the link at http://m0n0.ch/wall/ (pfSense is a fork of m0n0wall.)

    An easier option might be to use the web GUI: Diagnostics -> Backup/Restore to backup the configuration file to another system over the network.



  • That's a bug that has been fixed. Once git is settled we'll be putting out 1.2.3 with that fix. You can manually apply the fix by changing as shown here:
    https://rcs.pfsense.org/projects/pfsense/repos/mainline/commits/183c16d663d4dbab7834f8af8e23eb5b086c3e85



  • Thanks. But how to edit the image to change the value in the file? I tried to edit with Magic ISO, but after updating the file, error message appears when boot from CD - can't load 'kernel' .



  • There are 1.2.3 snapshots with that fix now. 
    http://snapshots.pfsense.org/FreeBSD7/RELENG_1_2/



  • Does anyone know how to burn Live CD from snapshots of 1.2.3 Release with Windows ?



  • Download a file with name like pfSense-1.2.3-20090129-0009.iso.gz, unzip it with winzip (or the like) to a file with a name like pfSense-1.2.3-20090129-0009.iso
    and use your CD burning program (Nero or the like) to burn a CD from this ISO image.


Locked