Not seeing rule description in logs



  • Added a new NAT today on OPT (DSL) interface today and watched the logs for a while.  All good.

    Once logging is disabled in the firewall rule, though, the earlier logs don't show the rule description.

    Maybe I just never noticed this but is it the expected behaviour?


  • Rebel Alliance Global Moderator

    Huh?  Those rules are different rules you can see that one if 5430, and other is 1540..



  • Yeah, sorry about the confusing screenshot.  I'm only talking about 1540.

    With logging set on for 1540 the rule description is shown.  Turn it off (as in the image) and the description disappears.

    Edit:

    Screencap with logging turned back on



  • Rebel Alliance Global Moderator

    Why would a rule that is not set to log be logged need a description ;)

    If something is not suppose to be in the log, why would the log need to show its description… So I would say its expected behavior to be honest..



  • @johnpoz:

    Why would a rule that is not set to log be logged need a description ;)

    If something is not suppose to be in the log, why would the log need to show its description… So I would say its expected behavior to be honest..

    Because it was set to be logged and is still in the log - at least until the log rolls over.  Sure, if the rule had been deleted, no description available.

    However, the rule IS still there, with its description (and pf label), so why have the display of the description depend on whether logging for the rule is currently disabled or not?

    Perhaps it is by design but I'd never noticed it before, so I thought I'd ask.  Day to day it's no big deal.