Re: Freeswitch for SOHO use (success stories or comments)



  • I hate to hijack this thread, but I've got freeswitch running on my pfsense firewall - it works great with flowroute and X-lite, but how do you begin to configure a Linksys SPA941 to work with it. I have looked all over the little web server that the phone has, and nothing looks familiar.

    Any help you can give would be most appreciated!

    Thanks -

    Mark



  • SPA941 open up the web interface. On the spa942 you press the settings button that looks like a paper icon then press 9. It will then show you the ip address of the phone. I like Firefox but the linksys web interfaces work best in IE. If you don't have a choice then make sure to wait until the page loads completely. Sometimes has an issue with Firefox.

    Click on the 'admin login' link on the right and then 'advanced'.

    For the example I will use extension 1001 and a password of ai3k4lhfz

    Ext 1 (tab)

    NAT Settings
    NAT Mapping Enable: yes
    NAT Keep Alive Enable: yes

    Proxy and Registration

    Proxy:
    Set the proxy which is the wan ip address or the domain name of FreeSWITCH (could use dyndns.org for dynamic dns) Which one ip or domain depends on how you have it setup.

    Subscriber Information

    Display Name: 1001
    Password: ai3k4lhfz
    User ID: 1001

    SIP (tab)
    NAT Support Parameters
    Handle VIA received: yes
    Insert VIA received: yes
    Substitute VIA Addr: yes
    STUN Enable: no

    Handle VIA rport: yes
    Insert VIA rport: yes
    Send Resp To Src Port: yes
    STUN Test Enable: no

    The settings I've provided for NAT are the best I have found so far. If someone comes up with something that works even better then please share. My attempts at stun slowed the call setup by too many seconds to be useful.

    By the way best to make sure your phone's firmware is upgraded to the latest. Unfortunately the SPA941 has not seen consistent upgrades like the SPA942 and SPA962. For new purchases go for one of those phones.



  • Thanks, mcrane - that got it working. Nice little phones.


Locked