[SOLVED] 2.3.4-RELEASE-p1 - Restarting every 15 minutes



  • We just updated to 2.3.4-RELEASE-p1 (from 2.3) and our pfSense server is now restarting every 15 minutes or so.

    We made no changes to the configuration.

    The only thing that we detected, is that the reverse proxy (Squid) stopped working as well.

    Any pointer on how can we troubleshoot this would be appreciated.


  • Rebel Alliance Global Moderator

    Why would you not have updated to 2.3.5p1?

    What does the log show?



  • 2.3.5 doesn't show as an update for us… It says we are up to date.

    We can't find a log right at the time the server crashes... we are still looking at it. Any pointer on how to get to it easily?


  • Rebel Alliance Global Moderator



  • Thank you! We'll check with clog.

    In the meantime, we were able to update to 2.3.5.



  • We are getting these errors in the log, as soon as we boot:

    
    Apr 17 15:52:30 pfsense kernel: random: <software, yarrow="">initialized
    Apr 17 15:52:30 pfsense kernel: ACPI BIOS Warning (bug): Invalid length for FADT/Pm1aControlBlock: 32, using default 16 (20150515/tbfadt-725)
    Apr 17 15:52:30 pfsense kernel: ioapic0 <version 2.0="">irqs 0-23 on motherboard
    Apr 17 15:52:30 pfsense kernel: wlan: mac acl policy registered
    Apr 17 15:52:30 pfsense kernel: ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    Apr 17 15:52:30 pfsense kernel: ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (ipw_bss_fw, 0xc081ee90, 0) error 1
    Apr 17 15:52:30 pfsense kernel: ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    Apr 17 15:52:30 pfsense kernel: ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc081ef40, 0) error 1
    Apr 17 15:52:30 pfsense kernel: ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    Apr 17 15:52:30 pfsense kernel: ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc081eff0, 0) error 1
    Apr 17 15:52:30 pfsense kernel: iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    Apr 17 15:52:30 pfsense kernel: iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (iwi_bss_fw, 0xc08469e0, 0) error 1
    Apr 17 15:52:30 pfsense kernel: iwi_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    Apr 17 15:52:30 pfsense kernel: iwi_ibss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (iwi_ibss_fw, 0xc0846a90, 0) error 1
    Apr 17 15:52:30 pfsense kernel: iwi_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    Apr 17 15:52:30 pfsense kernel: iwi_monitor: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (iwi_monitor_fw, 0xc0846b40, 0) error 1
    Apr 17 15:52:30 pfsense kernel: netmap: loaded module
    Apr 17 15:52:30 pfsense kernel: module_register_init: MOD_LOAD (vesa, 0xc1247770, 0) error 19</version></software,> 
    

    The server reboots even before we have time to edit /boot/loader.conf.local to add those two settings (although we are not sure those are needed).



  • Turned out to be our UPS being misconfigured, and shutting down the server while we blamed the update… sorry and thank you for helping!