Biostar TH61-ITX and PCI-e NIC's



  • As a last ditch effort, I decided to post this question here. I’m trying to repurpose a no longer used mini-ITX computer for pfSense. The motherboard is an Biostar TH61-ITX with an i5 CPU, 6GB RAM, a single onboard LAN, one card slot (PCIe), and the latest BIOS update.

    My issue is I can’t get any PCIe NIC’s to function in any operating systems with this motherboard. I’ve tried both a Supermicro-AOC-SG-i2 and a HP NC360T.  The cards fail to function correctly with the motherboard in pfSense (FreeBSD), Windows 10, and Fedora Linux. I know the cards are good as I can get them to work on similarly aged ASUS in pfSense and Fedora without any needed configurations or tweaks.

    On the Biostar TH61-ITH, the cards seemingly are correctly detected and identified (make, model, features, etc.) under all three O/S’s. The logs seem to indicate both cards are ready and functional. The O/S's correctly identifies the MAC addresses. The LED indicators on the cards illuminate when I plug in the cables as expected, but the operating systems indicate the network cable are disconnected. If I up and down the interfaces the LED light illuminate and go off as expected.  The cards won't get a DHCP address.  Still no traffic when I try assigning static address.

    I tried repeatedly resetting BIOS, and somewhat less systematically tweaking BIOS settings relating to the PCI-e slot, on-board LAN, on-board graphics, etc. Nothing has made any difference.

    I’m waiting for a follow-up response from Biostar support, but don’t expect a solution from them. I’m guessing this is a lost cause. The BIOS may simply not these (older) PCIe NIC’s or perhaps there is something wrong with the PCIe slot.

    Anyway, I thought I’d see if anyone had any suggestions before I discard the motherboard.

    Thanks,





  • Biostar's technical support was of little to no help.  This morning I finally decided to cut my losses (time-wise) and trashed the TH61-ITX motherboard and i5-2400 CPU.  I ordered a newer Gigabyte Mini-ITX motherboard and AMD Ryzen CPU from Newegg.  Life's short.  :-\

    Consider this thread closed… Thanks to all who read it.


  • Netgate Administrator

    Hmm, strange issue.

    Normally if it wasn't working I would not expect it to show up under pciconf correctly. If it does I would suspect a driver issue maybe but to see it fail in three OSes sure looks like some obscure hardware incompatibility.

    None the less you might try a FreeBSD 12 snapshot if you can that has newer drivers.

    Steve



  • "Cable Disconnected"  seems to signal a RJ45/cable/MDIX issue, but nah, it cannot be that simple.