Package Management broken?



  • Ouch…  OK, based upon the info in this thread (http://forum.pfsense.org/index.php/topic,13771.0.html), I might guess that this is somewhat intentional (taking the Package Management offline, for repair / tuning).

    Anyhow, I ran an upgrade, just moments ago, and upon attempt to reinstall all packages (the only one still installed being FreeSWITCH), it failed.

    I attempted to use the package manager, to reinstall package manually, and it tells me:  "Unable to communicate to http://www.pfsense.org/?gui20alpha. Please check DNS, default gateway, etc."

    Of course, I'm posting this from within the network which pfSense ;D guards, and although that isn't necessarily indicative of complete network health, have not seen any other signs of trouble...

    2.0-ALPHA-ALPHA
    built on Sun Jan 25 13:05:14 EST 2009
    FreeBSD 7.1-RELEASE-p2

    update - Further troubleshooting as follows:

    I've now gone thru my network, and determined all to be in good shape.  Gone, via web-browser, to url: http://www.pfsense.org/?gui20alpha, and found it to link-back to the main pfsense.org front page. Wondering, now, if maybe the package directory on server has been corrupted or deleted?



  • ya, i am also trying to find out when package list will be available again.



  • Should be ok now!



  • @ermal:

    Should be ok now!

    it is still the same.
    Unable to communicate to http://www.pfsense.org/?gui20alpha. Please check DNS, default gateway, etc.

    also, can't see anything in auto updater even though I select 2.0 in updater settings.



  • You should try another snapshot i do not think that a upgrade has the fix in such a short time.



  • @ermal:

    You should try another snapshot i do not think that a upgrade has the fix in such a short time.

    thanks, I can see packages now. I was hoping to see Freenas package. I read somewhere it would be available in 2.0



  • I am geting this error when i try to open any packages in pfsense 2.0

    Warning: fopen(/usr/local/pkg/squid.xmlid=0): failed to open stream: No such file or directory in /etc/inc/xmlparse.inc on line 169 Error: could not open XML input

    is anyone else seeing this

    and will it or can it be fix

    thanks



  • @ToxIcon:

    I am geting this error when i try to open any packages in pfsense 2.0

    Warning: fopen(/usr/local/pkg/squid.xmlid=0): failed to open stream: No such file or directory in /etc/inc/xmlparse.inc on line 169 Error: could not open XML input

    is anyone else seeing this

    and will it or can it be fix

    thanks

    Been there, posted that (http://forum.pfsense.org/index.php/topic,13771.0.html), and a temporary solution was given:  in the url in browser, change "xmlid=" to "xml&id="



  • @samu:

    thanks, I can see packages now. I was hoping to see Freenas package. I read somewhere it would be available in 2.0

    It used to be in the branch that was going to be 2.0, but that was years ago, it's been abandoned. It won't be available in the foreseeable future.


Locked