[SOLVED] Backup & Restore not working on different hardware



  • Hi all,
    I've been using pfSense for years on  APU1C4 + 16 GB m-SATA SSD : it always worked well.
    Two weeks ago I bought a new hw to be used as a backup in case the APU1C4 failed, but I preferred to buy an APU2C4 (also with 16 GB mSATA) as it is more recent.

    I installed pfSense without problems and connecting via console I can configure the ports to access webgui.
    APU2 does not have the same interfaces as APU1:  re0/1/2  on APU1,  igb0/1/2  on APU2
    Because the different interfaces names, when I try to restore the configuration exported from APU1 (with the Backup & Restore function) pfSense asks to re-associate the interfaces. I do it, save and then the reboot starts.
    At that point the following message appears in console:

    Press F10 key now for boot menu
    
    Booting from Hard Disk...
    /
    

    then nothing happens anymore: the system remains frozen.

    The versions of pfSense are identical: 2.4.3
    On the LAN interface I have defined a dozen or so Vlan, I don’t know if they can create backup and restore problems.

    I tried to do the following tests:

    1. manually edit the backup file so as to already put the correct names for the interfaces (igb0/1/2): doing so the restore is done but then the boot stops at the same point.

    2. immediately after installing pfSense on APU2 I tried to backup the default config and restore it on the same platform: it works (ie it does not stop at boot). It means the system can write/read  the configuration file.

    I do not know what other tests to do and unfortunately I can not figure out where the boot stops because no other error messages appear on console.

    Can anyone please help me?

    Thanks in advance,
    Andrea


  • Netgate Administrator

    Probably the console changed config at that point when the boot loader started. Try using some different console speeds, 9600, 115200, 38400 (if you came from much older hardware).

    Most likely it imported a console setting from the old config file. If you open the file you should be able to see that in the system section at the beginning.

    Steve



  • Hi Stephen,
    thank you very much: it's just like you said!  I wonder why I was convinced that the speed used by pfsense was 115200: my mistake…. :-[

    Unfortunately, the "native" restore function does not work well when there are VLANs, but changing the interface names by hand before restoring the config  eventually worked.

    Thanks again!
    Andrea


  • Netgate Administrator

    The default console speed has been 115200 for a while now. Since 2.2 at least. But if you updated from an older version it might have been 9600 and it keeps that setting.
    Some people set it to that to match the BIOS output so they can see the full boot sequence.
    The ALIX board had a default BIOS speed of 38400 and pfSense shipped with it set to match on that hardware.

    Steve