SG-1000 problems with initial setup when changing LAN and HTTP_REFERER



  • Hi guys,

    We have a few SG-1000 now and noticed that every time a new device is configured we have problems with losing access to the web interface. We get an error about HTTP_REFERER being enabled when you change the LAN address, so we can't access the web interface with old and new IP address.

    The only way around it to reset to factory and then disable this option on the firewall before configuring the LAN with a different address.

    We are using latest 2.4.3 version.

    Should this be reported as a bug?


  • Rebel Alliance Developer Netgate

    We've had a report of this before, but I could never replicate it. If you're running the wizard from LAN, normally your client would have to pick up an address in the new subnet and none of my tests had a client that could pull that off without manual intervention and by that time the GUI worked fine on the new address when I went back to it.

    Do you mind giving more detail about exactly what procedure you followed to make it happen, including actions taken on the client PC?



  • Hi jimp,

    We had to send the device onsite so I didn't have a chance to try it again. We will do another 20 branches over the next few weeks/months so I'll test it again and will report back here.

    Thanks!


  • Netgate Administrator

    You can disable the http-referer check from the command line by running:

    
    pfSsh.php playback disablereferercheck
    

    Though that shouldn't be required and the check is there for a good reason.

    Steve