DNS problem with synology and pfsense



  • Hello everyone,

    I'm fairly new to pfsense. So forgive me my rookie mistakes.
    Recently I've started using my watchguard firebox x550e with pfsense as my main router/firewall.
    My ISP is providing me with a fibre connection and a modem (which until recently I've been using as router).

    To switch from de ISP's router to the pfsense box, I've turn off most of the functions of the ISP's router and gave the pfsense box a static IP and put that in a DMZ (the pfsense is still behind the ISP's modem for converting the fibre signal to RJ45).
    I also copied all my settings I had in the old router (static IP's and port forwards for a NAS/webserver) to the pfsense box.
    Everything is working great, except for one thing;

    My synology NAS (xpenology in VM) is not getting it's DNS requests resolved. And my NAS cannot ping any of my other devices on the network (which I need for some home automation stuff).

    If I set the default gateway to 192.168.0.1 (ISP's modem), DNS request work alright. But not with 192.168.1.1 (my pfsense box).

    I've tried all kinds of things with DNS settings in the pfsense box. Still no luck.

    Do you guys have any suggestions?