Torrents freeze connection eventually on PFSense 2.4.3\. Is reboot only solution?



  • I run PFSense 2.4.3 on a Deciso system with AMD GX-416RA 1.6Ghz Quad Core CPU, 4GB DDR3 RAM and 4x Gbit Intel® 82574L network ports, one of which is connected to a 100Mbit up and down WAN glassfibre internet connection. The other three ports each have their own GBit LAN subnets.

    When I start downloading a torrent on a Synology NAS on one of the LAN subnets, everything is fine.
    When I start multiple torrents, the connection freezes. I can still access PFsense via the web browser.
    Rebooting then seems to be the only way to bring the connection back up again.
    I have tried running torrents on different machines in a different subnet that is connected to another network port, and after a while (varies from minutes to hours) the same thing happens.

    The PFSense system shows that I only use a few hundred (200 to 300) states out of 2000000.
    There are 6200000 firewall table entries available.
    The memory used is 8% of 3524MB.
    The CPU usage is also staying low, at about 2%.
    All of the above when downloading at about 35Mbit/sec.
    The torrents are limited by the NAS software to using 40Mbit max download bandwidth.

    What am I missing that could cause these freezes?
    What can I do to get the connection via PFSense up and running again without rebooting the whole system?
    Clearing the states didn't help.

    I have read several topics here and on Reddit about similar situations, but none of those seem to fit this setup or situation.



  • Unconstrained p-p apps tend to cause congestions. PFS fix is to enable Traffic Shaping, use TS's wizard is the easiest and on the second page it even has a p-p option you simply enable, give it lowest priority, input your 90% max upload/download speeds and presto.



  • When it's frozen, what happens if you do a ifconfig down of the WAN interface, then ifconfig up?

    Also is there anything here that's relevant?



  • Thank you, SammyWoo.

    I've had the traffic shaper run in different configurations since you suggested it, but the first couple of days the connection kept crashing every couple of hours despite the traffic shaper being up and running.
    Then I changed the port for torrents to use to one outside of the normal P2P range of ports that my ISP didn't seem to be messing with.
    That seems to have solved the problem.