GEOM: corrupt or invalid GPT detected, cannot boot firewall after restore backup



  • hey guys,

    I've pfsense running as a VM, I had to restore it from a Veeam backup and upon starting it up I'm getting the following attachment error message.

    GEOM: da0: corrupt or invalid GPT detected
    GEOM: da0: GPT rejected – may not be recoverable

    mounting from ufs:/dev/gpt/pfsense failed with error 19

    Does anyone have any clue where to begin? I'm reading a lot but I can only find very generic answer about ZFS on freebsd :/




  • I've booted pfsense iso and tried to mount /dev/da0 manually to see if I could copy the config.xml but I still get the GEOM error about corrupt or invalid GPT detected



  • What version of veeam are you using? Did you have open-vm-tools installed inside of pfSense? Did you enable the quiescence in the Veeam backup job?

    I have had this sort of thing before, it looks like something critical was writing to disk right when the backup job ran so it corrupted something.

    Do you have another point in time backup you can restore from?

    Can you try file-level backup restore job using veeam, pull the config.xml and restore that way?



  • Veeam 9.5
    vmtools installed
    Not sure if quiescence was enabled, I've already scrapped that pfsense instance and deployed a new one, had to reconfigure everything from scratch

    I don;t think it was a write issue, I had 30 days worth of backups and every single one of them had the same issue. I restored alreayd a few other pfsense firewalls and none had this issue restoring from Veeam.

    Bear in mind this was one of the first pfsense devices I deployed like 4+ years ago so it could be that some update screwed it up.

    I tried file level restore but I could not get the appliance working, as it was a urgent matter we just ended up reconfiguring it from scratch