No WAN detected from static IP from ISP



  • Hi,

    I've setup a new VM with pfsense, and it's all working well within the LAN environment, so now when I plug the modem directly to the pfsense, it cannot detect the WAN.

    1. I have a static IP from ISP, my current router is set to Automatic IP from ISP
    2. i have rebooted the modem (and pfsense)
    3. I've tried setting the IP and gateway manually.

    I've 4 NIC, only using 2 for now as WAN and LAN.





  • Well, of course it's going to fail if you're asking for a dynamic address and they only support static addresses.

    3. I've tried setting the IP and gateway manually.

    And?  What happened?

    Things you need to get from your ISP:

    IP address
    Subnet mask
    Upstream gateway
    Domain Name server(s)

    Configure your WAN with those items and you should be good.



  • As the third picture, shows it is still pending.

    Well, I assume my router an set "Automatic IP from ISP", it would be the same. I have set the IP, Subnet, Gateway from the values I gotten from edgemax router.



  • Well, your ISP is apparently not supporting a dynamic IP address, so you will wait forever in that Pending state if you set WAN for dynamic.

    I did ask you what happened when you entered the details manually, and you didn't answer that.  I can't help you if you don't want to answer my questions.

    At any rate, it looks like you need to do it manually.



  • I tried again with DHCP, after setting gateway manually and deleting it, and somehow it works. I did not reboot the modem, so I don't know what happended yesterday. Thanks, so false alarm.



  • At least it's working for you now.



  • Even if it's working through DHCP, it's still better to do KOM's solution and manually enter the static IP info.  That way, if there's ever an issue with DHCP, your firewall will still work fine using its static info.

    A note for other people: many ISPs do not even send static IP reservations over DHCP, so manually typing the static IP is the only way (and best way anyway).



  • Looks like I spoke too soon. I did some config, couldn't get it working, and then reverted back to a saved config which was working. Rebooted pfsense and modem, and No WAN.

    I set a static IP on the WAN and gateway.

    The more I'm setting routes, the more confused I get. It's giving me inconsistent results. I actually reverted once and got it working, ran into this problem below, and reverted back now, and back to this problem.

    https://forum.pfsense.org/index.php?topic=147909.0