Pfsense hanged, Help me.



  • Hi
    I have installed pfsense 2.4 on nexcom 5160 with 32 GB RAM that is used only as firewall and nat, throughput is 300 Mbit/s on SFP ports but after 5 hours device hanged.
    Could you help me?



  • Probably hardware.  Can't really tell much more than that without any other troubleshooting.  When you say 'hanged' is the PC totally dead?  No console input from keyboard?



  • I can not enter anything, No console input from keyboard.

    Do it has specific configuration for upper than 300Mbit/s bandwidth?



  • No, that's not your problem.  For the system to totally hang, that is almost always a hardware fault of some type.  Faulty CPU, bad power supply or source, high-static environment, bad peripheral card.  Something like that.



  • thanks for your answer.

    I have already changed hardware but this problem was too and there is other devices such as cisco, mikrotik ,… without any problem.



  • I don't know what to tell you.  I've never heard of pfSense hanging a system, and I know that GigE speeds are no big deal for it.


  • Netgate Administrator

    Are you really running 2.4.0? You need to upgrade if so.

    What config do you have on there? Which interfaces are you using?

    Do you see a crash report? Any error on the console when it stops responding?

    Try pressing 'Ctl+T' at the console when it appears to have hung. If it's waiting for some process that should show it.

    Steve



  • I'm running 2.4.3 (latest version of pfsense). interfaces are sfp (fibre port).
    system hanged (no crash) so any error show on the console.


  • Netgate Administrator

    And you were not able to get that error of there was one I assume? Or try Ctl-T at the console?

    Steve



  • Maybe try enabling syslog and pushing to syslog server and you might get some info regarding the last seconds prior to hanging system.