Upgrading from 2.3.4 to 2.4.0 hangs at db>



  • I'm tried to upgrade my pfSense from 2.3.4 to 2.4.0 but it's hanging up.
    It's running on VMware vSphere 5.5. I took a new snapshot before the upgrade attempt, and rolled it back after it failed.
    I had the virtual console opened while I did the upgrade from the GUI.
    It did all the downloading of the packages & then rebooted.
    On the second reboot it hangs with a db> prompt
    Attached are some screen shots.
    Any suggestions?

    ![2018-05-09 20_21_21-venus.tipping.lan - vSphere Client.png](/public/imported_attachments/1/2018-05-09 20_21_21-venus.tipping.lan - vSphere Client.png)
    ![2018-05-09 20_21_21-venus.tipping.lan - vSphere Client.png_thumb](/public/imported_attachments/1/2018-05-09 20_21_21-venus.tipping.lan - vSphere Client.png_thumb)
    ![2018-05-09 20_30_18-pfsense.tipping.lan - Status_ Dashboard.png](/public/imported_attachments/1/2018-05-09 20_30_18-pfsense.tipping.lan - Status_ Dashboard.png)
    ![2018-05-09 20_30_18-pfsense.tipping.lan - Status_ Dashboard.png_thumb](/public/imported_attachments/1/2018-05-09 20_30_18-pfsense.tipping.lan - Status_ Dashboard.png_thumb)


  • Rebel Alliance Developer Netgate

    Use 2.4.3, not 2.4.0. That was a known ESX issue fixed months ago.



  • Thanks, how do I force it to jump to 2.4.3?


  • Rebel Alliance Developer Netgate

    Depends on what you did initially, since you're on 2.3.4 you might try going to 2.3.5 first, but if you just told it to upgrade it should go straight to 2.4.3.

    It's also possible it's a problem with that VM on your ESX install. It may not like FreeBSD 11, which technically isn't compatible with ESX 5.5. At a minimum you should increase the VM hardware compatibility as high as you can, and then try it again.



  • My system now says "Unable to check for Updates".
    Any suggestions?
    I didn't change anything since my last post.

    ![2018-05-14 09_57_52-Window.png](/public/imported_attachments/1/2018-05-14 09_57_52-Window.png)
    ![2018-05-14 09_57_52-Window.png_thumb](/public/imported_attachments/1/2018-05-14 09_57_52-Window.png_thumb)



  • Try going to the Update Settings tab.  Then select some other version and save.  Now switch back and save again.



  • OK, I think that worked.
    I'll find out after hours.



  • OK, I got it to update from 2.3.4 to 2.3.5, but now it doesn't show any more updates after that.
    I've tried switching to all the other branches, & they all say it's up-to-date.
    Could this have to do with the FreeBSD 11 issue?
    Or is there another way I could get it to update to 2.4.3?

    ![2018-05-21 10_49_56-pfsense.tipping.lan - System_ Update_ System Update.png](/public/imported_attachments/1/2018-05-21 10_49_56-pfsense.tipping.lan - System_ Update_ System Update.png)
    ![2018-05-21 10_49_56-pfsense.tipping.lan - System_ Update_ System Update.png_thumb](/public/imported_attachments/1/2018-05-21 10_49_56-pfsense.tipping.lan - System_ Update_ System Update.png_thumb)