PfSense & Single Computer DNS Settings (OpenDNS)

  • First of all I want to mentioned that I'm switching from DD-WRT to the much more stable pfSense, and now I need to be very specific with how I setup everything in pfSense(DD-WRT was a little more forgiving… less secure?).  It's been quite a bit of learning, but it is already starting to show some ROI.

    Right now I'm stuck on this problem and have not been able to figure a solution for it.  My WAN is set to a static ip# and I have my ISP provided DNS entries inputed into the General Settings section of pfSense.  I have my Captive Portal turned on and everything was working fine.

    When it came for me to setup a single computer on the network to use the OpenDNS DNS servers, I was clueless on how to setup my pfSense to handle this.  What happens right now is that the computer works fine when it auto obtains the DNS entries of the ISP, but not when I manually input the OpenDNS entries.  It will not resolve DNS names when using the OpenDNS servers.

    I'm very unfamiliar on how the DNS Forwarding settings works and hope that someone could explain how I can get OpenDNS working on a single computer, without having the rest of the LAN using OpenDNS.

    Many thanks in advance.

  • try to let the ip without passing thru captive portal. U can let it pass thru MAC or IP. Be careful because the default rule it will overwrite the dns on LAN

  • Thanks for this info, I forgot about the captive portal blocking the DNS requests.  After setting a static ip for the client and allowing the ip to pass-through the captive portal everything works fine.

  • I would rather set the openDNS servers onto the "allowed IPs" list than allow the client alltogether.