FpSense Upgrade Score 0 out of 4 - why?



  • From the past few years of running pfSense, I have tried to do the upgrades from the Dashboard through 4 different versions. And every time, including today's from 2.3.4 to 2.4.3, it has failed - even though it always reports 'Sucessful'. And, yes, I wait a very long time for it to complete - watching the web page say

    'Still not ready. Waiting 20sec'

    again and again and again.
    After every upgrade attempt, the pc fails to boot and I must resort to installing a new copy of pfSense from a USB boot stick.
    Why? Why has it always failed?
    I can't find any full system status in pfSense (memory, disk, cpu, speed, etc), so attached are screenshots from the dashboard as well as a image of the system specs from the vendor.
    The latest errors I got when I tried to upgrade from 2.3.4 to 2.4.3 was a quick blink of

    'No Core Dump Found'

    followed by pages and pages of:

    Warning: PHP Startup: Unable to load dynamic library 'balabalabala': invalid file format in Unknown on line 0
    Warning: PHP Startup: Unable to load dynamic library 'balabalabala' - Shared object "libssl.so.7" not found. required by "openssl.so" in Unknown on line 0"

    The last lines I get are:

    pfSense 2.4.3-RELEASE amd64 Thu May 10 15:02:52 CDT 2018
    Boot complete
    FreeBSD/amd64 (Amnesiac) (tty0)
    Login:
    

    But no pfSense. No Menus, no options, just a login prompt and nothing else.
    The fact that I am on the internet now and can write this plea for help is only because I knew the upgrade would fail and has downloaded 2.4.3 to manually install in that event (which I really do appreciate that option, but it in a PITA to pull the PC out of the 'closet' hook it up to the tv & keyboard, load the USB stick and re-install the reload the old configuration). BTW, the new install looks very nice! 
    I hope someone can help point me to what I'm doing wrong or something that needs to be set to allow upgrades. This manual process is getting very old.
    Thank you.





  • Hi,

    I understand your question..
    This is what I saw yesterday  https://pastebin.com/aUAv10ic - the upgrade went just fine - it rebooted, and was up after a minute or so. It's like this the last several (10 ?) years. Can't remember it broke something (except for bad SAT drives - bad DDRAM ….).

    Two advises :
    Before upgrading, restart your pfSense.
    After restating, check dmesg log (go god mode, option 8 and type dmesg - check for errors, document yourself about the errors ans warnings).
    Make a config copy.
    Then upgrade.

    Btw : an upgrade log exists. If new pfSense "core files" can't be written (overwritten) I would for sure want to know why they didn't copy.

    The only difference between your pfSense setup, and mine is :
    NOT pfSEnse, the code is identical.
    Your are probably using other FreeBSD drivers, because your hardware is different.
    Your config is different, our are using probably other packages as I do.



  • Thank you!
    I'll bookmark this page and go through those items next time I attempt and upgrade and it fails.  :)