2.4.3.1 update issues



  • As others have reported, I've also had a number issues with the latest update:

    1. The update failed, but after waiting and a reboot the router reported the update sucessful
    2. However, the WAN gateway config was wiped
    3. My openVPN server is reported "fatal error". Log below:

    May 21 09:19:18 openvpn 8579 Exiting due to fatal error
    May 21 09:19:18 openvpn 8579 Cannot load certificate file /var/etc/openvpn/server1.cert
    May 21 09:19:18 openvpn 8579 OpenSSL: error:140AD009:SSL routines:SSL_CTX_use_certificate_file:PEM lib
    May 21 09:19:18 openvpn 8579 OpenSSL: error:0906D066:PEM routines:PEM_read_bio:bad end line
    May 21 09:19:18 openvpn 8579 NOTE: the current –script-security setting may allow this configuration to call user-defined scripts
    May 21 09:19:18 openvpn 8579 GDG: problem writing to routing socket
    May 21 09:19:18 openvpn 8542 library versions: OpenSSL 1.0.2m-freebsd 2 Nov 2017, LZO 2.10
    May 21 09:19:18 openvpn 8542 OpenVPN 2.4.4 amd64-portbld-freebsd11.1 [SSL (OpenSSL)] [LZO] [LZ4] [MH/RECVDA] [AEAD] built on Mar 16 2018



  • These files :

    [2.4.3-RELEASE][admin@pfsense.brit-hotel-fumel.net]/root: ls -al /var/etc/openvpn
    total 32
    drwxr-x---  2 root  wheel   512 May 15 18:13 .
    drwxr-xr-x  5 root  wheel  1024 May 20 12:52 ..
    -rw-------  1 root  wheel  1615 May 15 18:13 server1.ca
    -rw-------  1 root  wheel  1765 May 15 18:13 server1.cert
    -rw-------  1 root  wheel  1256 May 15 18:13 server1.conf
    -rw-------  1 root  wheel     3 May 15 18:13 server1.interface
    -rw-------  1 root  wheel  1704 May 15 18:13 server1.key
    srwxrwxrwx  1 root  wheel     0 May 15 18:13 server1.sock
    -rw-------  1 root  wheel   657 May 15 18:13 server1.tls-auth
    
    

    should exists if openvpn server is setup and should run.

    If files can't be created, it's time to check your media.



  • Thanks. Those files existed, though several were 0 bytes.

    The update wiped all my settings for various packages also: pfBlockerNG, Snort, Squid.

    I decided to do a clean install of V2.4.2 to my router, then did an upgrade to 2.4.3.1 via the GUI without issue. Now, I'm updating my config and various packages. So far, so good


Log in to reply