VoIP woes



  • Hi, I'm hoping somebody can take a few minutes to assist a baffled newbie with some traffic shaper questions. I'm running version 1.0-RC1 on a cable modem and am trying to get a fairly simple set of rules to work. As far as the network goes, I have 2 computers and a Vonage device. I'm looking for rules to give VoIP traffic top priority, HTTP & VNC traffic second priority, NNTP traffic third priority, then let P2P traffic use whatever bandwidth is left.

    The problem I have been running into is that P2P traffic continues to choke the upload pipe no matter how I've tried set it up. I can see traffic going into the correct queues, but web surfing is still slowed to 56k speeds and VoIP traffic has an incredible lag on transmission and sounds broken and garbled on the other end. At this point the only thing I can think of to try is to put a hard limit on P2P max bandwidth. I'd prefer to keep that as a last resort as the computers go unused while I'm at work and P2P programs may as well use all the bandwidth they want during that time.

    I've attached my traffic shaper config file. Can someone take a peek at it and see if you can figure out where I've gone horribly awry?
    shaper-config-pfsense.xml.txt



  • Haven't verified the configfile yet but some general advices:

    • use the shaperwizard, it usually knows what it sets up (I guess you did that already)
    • don't trust the speed your provider advertizes for your line. do some tests or substract a fair amount of bandwidth for the up and downstream first and try to find the toplimit after it is working with the bandwidthlimits you put first. if your modem starts to queue the connections trafficshaping won't work
    • Enter the IP of your vonage device when the shaper asks for voip in the red field. Set a valid bandwidth depending on you codec and how many calls should be possible at the same time
    • use the P2P-Catch-All checkbox at the P2P wizardscreen
    • at other protocols choose the rest of your apps to be prioritized or lowered in priority
    • after the filter has reloaded, reset states at diagnostics>states, reset states. traffic is assigned to a queue when a connection is established. already established connections will remain in the queue they were running previously unless you reset the states


  • The rest of the stuff I had already checked on, but somehow I neglected to do a recent speed test. Sure enough, the line tested at 230 Kb up, not the 256 I used to be getting when I checked it a couple months ago. After adjusting that, everything seems to be running a lot smoother. Thanks for the advice!


Log in to reply