LAGG on Switched Ports on SG-3100



  • Is it possible to create a LAGG on LAN1,LAN2 on SG-3100?

    Running 2.4.3.RELEASE-p1
    Using OPT1 for mgmt, I have:

    -Deleted the LAN interface in Interfaces/Assignments.
    -Enabled 802.1q VLAN Mode in Interfaces/Switches/VLANs.
    -Remove all ports except 5 from VLAN Group 0  (VLAN Group 0 / VLAN Tag 1 / Members 5)
    -Rebooted.

    There is no option to do anything under Interface/Switch/LAGGs.

    Thank you.



  • I was able to do this on the command line and make it persistent using the 'shellcmd' package.

    0_1528318050294_Screenshot-2018-6-6 router mgmt - Package Services Shellcmd Settings.png

    0_1528318058507_Screenshot-2018-6-6 router mgmt - Interfaces Switch LAGGs.png

    Make sure all of the ports in the LAGG have the same VLAN configuration if you're using VLANs. Also, the SG-3100 switch doesn't seem to do LACP, so the other side of the LAGG needs to support static link aggregation. My Unifi switches only support 802.3ad/LACP aggregation and so they would not talk to the SG-3100 switch LAGG, but my EdgeSwitch does support static aggregation, and it works great.



  • Hi @iamjamestl

    Thank you for this, I can't find anything else on this topic at all!

    I'd like to do this with a pair of Cisco C3750Gs but I can't get it working. The LAGG is created and displayed under LAGGs as you have described, but my switches complain of PfSense flapping between the two ports.

    I configured it as a Static LAGG on the switch stack but pfsense just grinds to a halt everytime I do it as if it's causing some kind of network loop.

    Any ideas?

    My switch config is;
    !
    interface po10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Gi1/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 10 mode on
    !
    interface Gi2/0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 10 mode on
    !



  • @tehmuffinmoo, what EtherChannel load balancing option have you selected on the Cisco? Based on my limited experimentation, the SG-3100 switch only supports L2 load balancing. I have my Ubiquiti EdgeSwitch set to load balance based on "Src/Dest MAC, VLAN, EType, incoming port."



  • Hi @iamjamestl

    Thanks for the reply! I hadn't set anything specific for loadbalancing method, so I presume whatever is default. (I've no idea!)

    However, I re-tested last night using ports 3,4 instead of my production ports 1,2. This time I didn't get any MAC address flapping errors on the switch but if I pulled out cable A everything continued working. If I swapped them and pulled out B everything would drop. I left it for a good 10-15 minutes while I went and got a brew and it never moved over to the other interface, despite the port channel being up on the switch.

    So good news is I don't get port flapping, bad news is PfSense seems to only be using 1 NIC.



  • @tehmuffinmoo, I think you just discovered the "static" part of "static LAG." Normally, LACP would be responsible for renegotiating the LAG on network topology changes, but LACP is disabled for static LAGs. A better test would be to start multiple, high-bandwidth streams from different devices and observe the bandwidth utilization on all the ports of the LAG.



  • @iamjamestl

    Forgive me, I'm no Network Engineer. My interpretation (assumption?) was that a static LAG wouldn't failover existing states but new connections would be transmitted down the link which was up.

    I'm now guessing this is not the case? Do Static LAGs only provide additional bandwidth and no form of resilience?



  • ah! I was just asking about the same over here https://forum.netgate.com/topic/133949/sg-3100-lagg-lacp-with-switch/7

    By the way, can anyone point to documentation, or clearly explain how the L2 "Loadbalancing" option works? Say I connect my SG3100 via such bond to a switch .. both SG3100 and Switch then have two hosts each connected via 1GBe: A and B to router and C and D to switch. If host A talks to C and D talks to B .. will I be using the full 2GBe bandwidth?

    Morever, do you think it makes sense to create a 2 port LB or 3 ports? given that the Marvel switch on the SG3100 is 2.5Gb ? Or since the switch can only talk to other 2 GBe (WAN and OPT1), then 2 GBe ports will be enough?

    Thanks!